Add ALLOC_CLEAR_BUFFER flag for SKIA in TextureClient::CreateForRawBufferAccess()

RESOLVED DUPLICATE of bug 1413862

Status

()

Core
Graphics: Layers
P3
normal
RESOLVED DUPLICATE of bug 1413862
10 months ago
7 months ago

People

(Reporter: sotaro, Assigned: sotaro, NeedInfo)

Tracking

unspecified
Points:
---

Firefox Tracking Flags

(firefox57 fix-optional)

Details

(Whiteboard: [gfx-noted])

Attachments

(2 attachments)

(Assignee)

Description

10 months ago
ALLOC_CLEAR_BUFFER flag is added in TextureClient::CreateForDrawing() for TextureClient::CreateForRawBufferAccess(). But the CreateForDrawing() is not the only caller of the CreateForRawBufferAccess().
(Assignee)

Comment 1

10 months ago
Created attachment 8887314 [details] [diff] [review]
patch - Add ALLOC_CLEAR_BUFFER flag for SKIA in CreateForRawBufferAccess()
Assignee: nobody → sotaro.ikeda.g
(Assignee)

Updated

10 months ago
Attachment #8887314 - Flags: review?(jmuizelaar)
What motivated this change? Was something broken?
Flags: needinfo?(sotaro.ikeda.g)
(Assignee)

Updated

10 months ago
Flags: needinfo?(sotaro.ikeda.g)
Attachment #8887314 - Flags: review?(jmuizelaar)
(Assignee)

Comment 3

10 months ago
I did not saw the actual breakage. Then it might not necessary.
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → INVALID
(Assignee)

Updated

10 months ago
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
(Assignee)

Comment 4

10 months ago
(In reply to Jeff Muizelaar [:jrmuizel] from comment #2)
> What motivated this change? Was something broken?

I did not saw the actual breakage. Original motivation was that CreateForRawBufferAccess() has the following code.

>  // D2D backend does not support CreateDrawTargetForData(). Use CAIRO instead.
>  if (aMoz2DBackend == gfx::BackendType::DIRECT2D ||
>      aMoz2DBackend == gfx::BackendType::DIRECT2D1_1) {
>    aMoz2DBackend = gfx::BackendType::CAIRO;
>  }

If it is fallback to SKIA instead of CAIRO, it seemed cause the breakage.
(Assignee)

Comment 5

10 months ago
Created attachment 8889809 [details] [diff] [review]
patch - Make skia as RawBufferAccess fallback backend of BackendType::DIRECT2D
(Assignee)

Comment 6

10 months ago
Comment on attachment 8889809 [details] [diff] [review]
patch - Make skia as RawBufferAccess fallback backend of BackendType::DIRECT2D

:jrmuizel, original intent was for making skia as RawBufferAccess fallback backend of BackendType::DIRECT2D. The patch does it. How do you think about it?
Attachment #8889809 - Flags: feedback?(jmuizelaar)
Review ping.
status-firefox57: --- → fix-optional
Flags: needinfo?(jmuizelaar)
Priority: -- → P3
Whiteboard: [gfx-noted]
(Assignee)

Updated

7 months ago
Status: REOPENED → RESOLVED
Last Resolved: 10 months ago7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1413862
(Assignee)

Updated

7 months ago
Attachment #8889809 - Flags: feedback?(jmuizelaar)
You need to log in before you can comment on or make changes to this bug.