If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

mail window headers incorrect, INBOX.msf file problem

RESOLVED WORKSFORME

Status

MailNews Core
Backend
--
major
RESOLVED WORKSFORME
16 years ago
9 years ago

People

(Reporter: chip piller, Assigned: Bienvenu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
I'm using mozilla 0.9.9 on Redhat 7.2, Help->About Mozilla: Mozilla/5.0 (X11; U;
Linux i686; en-US; rv:0.9.9) Gecko/20020311.

I've noticed a couple of problems when using mozilla mail.  However, this
problem has just happened again, so now I'm reporting it.  My name is Chip.  I
received an email with an attachment from Dave.  I saved the attachment to my
home area.  I created a new email that I sent to Steve.  The new email shows up
in the top right mozilla mail window (my Inbox) incorrectly.  The new email that
Chip sent to Steve shows up in the top right window as being sent by Dave, and
it has copied the subject and date info from Dave's email.  The new email shows
the correct information in the bottom right window, and the message source is
correct as well.  

As I said, this has happened a few times, I can provide screen shots if
necessary, I don't know if this has to do with me saving an attachment from the
other email.
(Reporter)

Comment 1

16 years ago
Created attachment 79804 [details]
mozilla mail inbox window error

Updated

16 years ago
Severity: normal → major
(Reporter)

Comment 2

16 years ago
Same problem happened today using mozilla 1.0rc1.

Yesterday I uninstalled Mozilla 0.9.9. I downloaded
mozilla-i686-pc-linux-gnu-1.0rc1-sea.tar.gz, installed it, it's been running
since yesterday.  

This morning I started to compose three email messages, and left them open for a
couple of hours.  I then forwarded three or four other emails, as well as
sending two of the emails I composed.  One of the emails I composed and sent is
showing up in the top right mail window with the subject, sender, date
information from one of the emails that I forwarded.

What other information can I provide to help figure out this bug?
(Reporter)

Comment 3

15 years ago
Update:  Encountered same problem today using Mozilla 1.0.  I found a file named
INBOX.msf down in my mozilla ImapMail subdirectory.  I moved this file,
restarted mozilla, started mail, my machine then proceeded to download about
1000 header messages from the imap server.  The INBOX.msf file was re-created
and the mail header problem was corrected.
Somehow my INBOX.msf file was written to incorrectly earlier when I was using
mozilla (quite heavily I might add, several windows/emails).  Any ideas? 
Summary: mail window shows incorrect email information → mail window headers incorrect, INBOX.msf file problem

Comment 4

15 years ago
When I select "Empty Trash". My Local Trash 
 folder disappears and my mail filters that were pointing to
 trash, disable themselves because they can no longer find it. Deleting the 
 Trash.msf file brings back the folder, but it was not emptied.

 Methinks some Netscape database file has become corrupted. :-(
 Deleting all the *.msf files, which worked to fix the original problem of 
 non-updating folders, is no longer working.
It brought down netscape and forced a talk back. 

Updated

15 years ago
QA Contact: olgam → laurel

Updated

14 years ago
Assignee: sspitzer → bienvenu
Component: Mail Window Front End → Mail Database
QA Contact: laurel → esther
(Assignee)

Comment 5

14 years ago
the first bug is fixed, I believe - can you try reproducing it on 1.6a? Or the
second problem, for that matter? Mozilla 1.0 was a long time ago.
Component: Mail Database → Mail Back End

Comment 6

13 years ago
This bug is really old. Can anyone reproduce this problem? If not, this bug can
be resolved.
(Reporter)

Comment 7

13 years ago
I've not encountered this problem in quite some time, I believe that the bug has
been fixed.  
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
(Assignee)

Comment 8

13 years ago
reopening to close wfm
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
(Assignee)

Updated

13 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.