smile.co.uk - form text input cannot be selected with mouse

VERIFIED FIXED

Status

Tech Evangelism Graveyard
English Other
--
major
VERIFIED FIXED
16 years ago
3 years ago

People

(Reporter: patrick, Unassigned)

Tracking

({conversion})

Details

(Whiteboard: [bug248549notfixed], URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9+) Gecko/20020412
BuildID:    2002041221

I am having problems filling in a form. 3 text input elements (for a date) do
not appear to work correctly, I can select them using TAB and sequentially
moving through each object in the form, however if I try and select them with
the mouse I can't!
In order to reproduce the problem go to url:
http://www.smile.co.uk/servlet/ContentServer?pagename=OpenMarket/Xcelerate/smView&c=Page&cid=971606262122&inifile=futuretense.ini;futuretense_xcel.ini
Then click on the "apply now" image on the right. A new window will popup and
load a form (incidentally this will not work if "Scripts/Windows"->"Open
unrequested windows" is not checked).
Ignore this first form and scroll down and click on next for a new form. This
form will have a number of checkboxes and followed by 3 text fields for a date
of birth. These are the fields that cannot be selected.

Reproducible: Always

Comment 1

16 years ago
Confirm. You can't focus _anything_ in the window. Kicking over to saari for
some triage.
Assignee: attinasi → saari
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

16 years ago
Changing QA contact
QA Contact: petersen → moied

Updated

16 years ago
Priority: -- → P3

Comment 4

16 years ago
The Smile "PC Checkup" page at
http://www.smile.co.uk/cgi-bin/compatibility/smiletest.cgi says that Netscape 6
is not supported. Also note that they don't even try to support Macs. A pity, I
was going to change over to them! Is this an Evangelism issue?
Site has the following code:

if (document.layers) {
  window.captureEvents(Event.MOUSEDOWN);
  window.onmousedown = function(e) { if (e.target==document){ return false; } };
} else {
  document.onmousedown = function(){return false;}
}

So all mousedown events are cancelled.  Since text inputs are focused on
mouse-down, the site is explicitly making them not focusable with a mouse.
Assignee: saari → nitot
Component: Layout → Europe: West
Priority: P3 → --
Product: Browser → Tech Evangelism
QA Contact: moied → brantgurganus2001
Version: Trunk → unspecified
Summary: form text input cannot be selected with mouse → smile.co.uk - form text input cannot be selected with mouse

Comment 6

15 years ago
tech evang june 2003 reorg
Assignee: nitot → english-other
Component: Europe: West → English Other
QA Contact: brantgurganus2001 → english-other

Comment 7

14 years ago
I just got a reply which a little bit of a lie in it, but at least they seem to
be taking it seriously.  About to reply with some instructions on how they can
fix the code...

 I'm sorry that you're unimpressed with the service. When we first developed
 and implemented the banking service it worked without any problems however
 since then Mozilla have made some key changes to the way that it handles
 JavaScript.

 We're working on a fix to this problem and we hope to have a new service
 running soon. The new [sic]

Comment 8

14 years ago
Here's the message I just sent them:

Hi,

Thanks for the prompt reply.  I had a look at the code and came up with a couple
of small fixes that will allow it to work in both Internet Explorer and
Mozilla-based browsers.  Hopefully this will help get it fixed more quickly :-)

The page I was looking at was:

https://welcome5.smile.co.uk/servlet/SmileEnrolment?&CurrentPage=ExistingCustomer#

The main problem is that the script on the sign-up page sets the onmousedown
event to 'false', which means when you click on a form field, it prevents you
from entering anything in it.  I'm not sure why that's there, but anyway, the
page works fine without it.

The other problem is with the event handling code on the forms.  It uses an
IE-only approach (i.e. assuming a global 'event' object, and the existence of a
srcElement attribute on it).

This code works fine:

document.onkeydown = function(e){
 if (window.event) {e = event}
 if( e.keyCode == 8 ) {
   backspaceflag=true;
   if (e.target) {
     src = e.target;
   } else {
     src = e.srcElement;
   }
   if (src.type == "text" || src.type == "textarea" || src.type == "password") {
     return true ;
   } else {
     return false;
   }
  } else {
  backspaceflag=false;
  }
 };

Finally, 'document.all' is used in a few places, and is not supported in
Mozilla-based browsers for getting elements.  getElementById is supported in IE5
and above, and as that's your minimum recommended IE browser, you could use that
instead without a problem.

I hope that's helpful.

Seb

Comment 9

14 years ago
Answer from smile: they are not able to make *any* changes to the site for
possibly another 8 months.

Hello

Thanks for the suggestions. I've passed them on to our website team.

As Chris nearly said (although it looks like he hit the "send" button too
early - sorry about that), we're testing a new system at the moment, that
will be far more Mozilla friendly. It should work on more browsers and on
more platforms than before.

We've held up any changes to the existing site, to allow our testing team
time to devote to getting the new system ready. It should be unveiled before
the end of the year, if all goes well.
(Reporter)

Updated

14 years ago
Keywords: conversion

Updated

14 years ago
Whiteboard: [bug248549notfixed]

Comment 10

14 years ago
I am new to tech evangelism, but just thought I'd point out this bug appears to
have been fixed. I use Mozilla 1.7.3 on WinXP (Gecko/20040910). I have been
aware of this bug since I started banking with smile a few years ago. They have
recently (about 1 month ago) upgraded their system. One upshot of which appears
to be that form text input fields can now be selected with a mouse or otherwise
in smile. I don't want to change the status of this bug, since I am new. But as
far as I can tell it has been resolved.
(Reporter)

Comment 11

14 years ago
I cant fully verify this since I no longer have a smile account and all the urls
in the various comments do not work any longer. However, the main login page
does in fact work and if Robin Massart claims it works I have no reason not to
believe him. I will mark this bug as fixed.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 12

14 years ago
I am a smile customer, and I can confirm that they've fixed this (along with a
bunch of other accessibility issues) with the changes that went live a few weeks
ago.
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.