Internet Citizen blog header image issue

RESOLVED WONTFIX

Status

www.mozilla.org
Pages & Content
RESOLVED WONTFIX
9 months ago
9 months ago

People

(Reporter: malexis, Unassigned)

Tracking

Production

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 months ago
Created attachment 8887540 [details]
Screen Shot 2017-07-18 at 6.47.51 AM.png

When adding a header image to a blog post, it gets cropped and does not display the full image.

This seems to be recurring and most likely a template issue that occurs across the WP platform.

Resizing image doesn't fix.

Is there a solution that will fit the entire image on the page?
This is by design. The featured images are automatically scaled to a 16:9 ratio, but we found that showing the full image on the single post page pushed the content too far down and the image was way too dominant. So the top and bottom of the featured image is cropped off on article pages, and ideally authors should choose images that don't have vital content along the top and bottom edges.

When we were designing this theme we intended the featured images to be "mood-setting" editorial illustrations, stock photos, etc, not essential content. Now that it's in the wild we consistently find that authors are using featured images as text banners, and complaining when their content gets cut off. We could just keep saying "well, don't do that" but that's a blunt retort against the user's natural expectations. At this point I think it's time to redesign how those images appear on article pages. Maybe we can find a way to avoid cropping without it taking over the entire screen.

Until we can redesign the page layout the immediate solution is still to choose a different image that lends itself to cropping or resize your image so the important content is in the center.
(Reporter)

Comment 2

9 months ago
Thanks for the clarification, Craig. 

I'll close this out for now.
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.