Closed Bug 1381915 Opened 3 years ago Closed 3 years ago

Upgrade in-tree version of voluptuous

Categories

(Release Engineering :: General, defect)

defect
Not set

Tracking

(firefox56 fixed)

RESOLVED FIXED
Tracking Status
firefox56 --- fixed

People

(Reporter: catlee, Assigned: catlee)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

We have 0.8.11 in-tree. Latest version on pypi is 0.10.5.

This speeds up task generation on my system.

Before:
time ./mach taskgraph target -p parameters.yml
26.38s user 0.19s system 99% cpu 26.594 total

After:
time ./mach taskgraph target -p parameters.yml
11.42s user 0.17s system 99% cpu 11.672 total
Assignee: nobody → catlee
Attachment #8887565 - Flags: review?(ahalberstadt) → review?(dustin)
This looks good to me, but dustin should give this the final ok.
Comment on attachment 8887565 [details]
Bug 1381915: upgrade voluptuous to 0.10.5

https://reviewboard.mozilla.org/r/158428/#review163820

::: third_party/python/voluptuous/CHANGELOG.md:1
(Diff revision 1)
> +# Changelog
> +
> +## [Unreleased]
> +
> +## [0.10.5]
> +
> +- [#278](https://github.com/alecthomas/voluptuous/pull/278): Unicode
> +translation to python 2 issue fixed.
> +
> +## [0.10.2]
> +
> +**Changes**:

Actually, I think gps usually insists on checking the unzipped wheels. I think you can do this with:

    $ pip install wheel
    $ pip wheel voluptuous
    $ unzip voluptuous-0.10.5-py2-none-any.whl

Then add the files in the resulting "voluptuous" folder. That way we don't have to include all this changelog/package cruft.

I filed bug 1346026 awhile back to add some sort of automatic vendoring mechanism.
Comment on attachment 8887565 [details]
Bug 1381915: upgrade voluptuous to 0.10.5

https://reviewboard.mozilla.org/r/158428/#review163822

I had *some* reason for not using the latest voluptuous.  I remember being concerned that 0.8.x was one file, whereas later versions were a bunch of Python packages, but it's not like it's MB's of code.  Maybe there was some bug in the latest version that is now fixed?  I don't remember :(

Anyway, since this works now and is faster to boot, let's do it!
Attachment #8887565 - Flags: review?(dustin) → review+
Comment on attachment 8887565 [details]
Bug 1381915: upgrade voluptuous to 0.10.5

https://reviewboard.mozilla.org/r/158428/#review164114

Thanks!
Attachment #8887565 - Flags: review?(ahalberstadt) → review+
Pushed by catlee@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c783e87dc7fd
upgrade voluptuous to 0.10.5 r=ahal,dustin
Yes, we don't like checking in wheels because they are opaque. .whl files are just zip files. So you can unzip them and vendor. Or you can clone the underlying repo they came from and copy files from a specific commit.
This change may cause issues due to a cached voluptuous.pyc file. Source directory clobbers (mach clobber python) may be required.
Come to think of it, I think glandium coded up some Python importer magic a while back to verify the .py file exists before attempting to use a .pyc. So I think we may be good.
Duplicate of this bug: 1357608
Blocks: fastci
https://hg.mozilla.org/mozilla-central/rev/c783e87dc7fd
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.