Closed Bug 1381933 Opened 3 years ago Closed 3 years ago

Intermittent reftest/tests/gfx/tests/crashtests/783041-2.html | application timed out after 330 seconds with no output

Categories

(Core :: Graphics, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla56
Tracking Status
firefox56 --- fixed

People

(Reporter: aryx, Assigned: milan)

References

Details

(Keywords: intermittent-failure, Whiteboard: [gfx-noted][stockwell fixed:other])

Attachments

(1 file)

https://treeherder.mozilla.org/logviewer.html#?job_id=115332190&repo=autoland

[task 2017-07-18T17:52:07.162181Z] 17:52:07    ERROR - REFTEST ERROR | file:///home/worker/workspace/build/tests/reftest/tests/gfx/tests/crashtests/783041-2.html | application timed out after 330 seconds with no output
Interesting:

[task 2017-07-18T17:46:37.167591Z] 17:46:37     INFO - --DOMWINDOW == 45 (0x7fd9d1ab7800) [pid = 1013] [serial = 2500] [outer = (nil)] [url = file:///home/worker/workspace/build/tests/reftest/tests/gfx/tests/crashtests/783041-2.html]
[task 2017-07-18T17:46:37.168232Z] 17:46:37     INFO - --DOMWINDOW == 44 (0x7fd9995e9000) [pid = 1013] [serial = 2501] [outer = (nil)] [url = file:///home/worker/workspace/build/tests/reftest/tests/gfx/tests/crashtests/783041-2.html?10]
[task 2017-07-18T17:46:37.168406Z] 17:46:37     INFO - --DOMWINDOW == 43 (0x7fd9ce460800) [pid = 1013] [serial = 2502] [outer = (nil)] [url = file:///home/worker/workspace/build/tests/reftest/tests/gfx/tests/crashtests/783041-2.html?9]
[task 2017-07-18T17:46:37.169482Z] 17:46:37     INFO - --DOMWINDOW == 42 (0x7fd999a5f000) [pid = 1013] [serial = 2503] [outer = (nil)] [url = file:///home/worker/workspace/build/tests/reftest/tests/gfx/tests/crashtests/783041-2.html?8]
[task 2017-07-18T17:46:37.170122Z] 17:46:37     INFO - --DOMWINDOW == 41 (0x7fd9ce361800) [pid = 1013] [serial = 2504] [outer = (nil)] [url = file:///home/worker/workspace/build/tests/reftest/tests/gfx/tests/crashtests/783041-2.html?7]
[task 2017-07-18T17:46:37.170770Z] 17:46:37     INFO - --DOMWINDOW == 40 (0x7fd9ce454000) [pid = 1013] [serial = 2505] [outer = (nil)] [url = file:///home/worker/workspace/build/tests/reftest/tests/gfx/tests/crashtests/783041-2.html?6]
[task 2017-07-18T17:46:37.170905Z] 17:46:37     INFO - --DOMWINDOW == 39 (0x7fd9d46ea800) [pid = 1013] [serial = 2506] [outer = (nil)] [url = file:///home/worker/workspace/build/tests/reftest/tests/gfx/tests/crashtests/783041-2.html?5]
[task 2017-07-18T17:52:07.162181Z] 17:52:07    ERROR - REFTEST ERROR | file:///home/worker/workspace/build/tests/reftest/tests/gfx/tests/crashtests/783041-2.html | application timed out after 330 seconds with no output

So, we reload (by setting a new search value) 6 times, each time taking less than a second (you'd hope so), and then we get stuck for five and a half minutes.  But, this is a different than the 20 minute timeout from before, though it would probably hit the same one - do we have other runs with failures?  Do they always show up after 6 reloads (e.g., the last valid url has ?5 at the end)?
Flags: needinfo?(aryx.bugmail)
Assignee: nobody → milan
Priority: -- → P1
Whiteboard: [gfx-noted]
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1381933 has 4 failures now (and one mistagged one). 3 of them show the issue after 6 reloads.
https://treeherder.mozilla.org/logviewer.html#?repo=autoland&job_id=115310624&lineNumber=20031 doesn't have "783041-2.html?"
Flags: needinfo?(aryx.bugmail)
Based on conversation in bug 1381283 comment 7, this whole thing started with bug 1362903.  Samael, can you take a look?  It stands to reason that resetting gCurrentURL would mess with a test that does a page reload :)
Flags: needinfo?(sawang)
Flags: needinfo?(jmaher)
I do not see how resetting that variable is causing issues- I recommend backing it out until we determine what is going on here.  Possibly this is an issue with crashtests only?
Flags: needinfo?(jmaher)
I'm looking into this (and bug 1381839).
Anyone know how I could enable MOZ_REFTEST_VERBOSE on try server to get debug log? --setenv MOZ_REFTEST_VERBOSE=1 doesn't work for me...
I found that if the reload happened during RecvClear(), it's possible that there would be no load event comes from the blank URL but from previous test document. It was working in the past since in this case there would be another TEST-PASS for the previous test document, and that would cause another RecClear(). 

As a workaround we can retry load the blank page, if gClearingForAssertionCheck is true but the load event comes from another document. I'm making more try runs to verify it.

That, however, in conjunction with bug 1362903, imply these reload test cases have been implemented incorrectly. I think there should be a "reftest-wait" in these test cases to ensure they are not considered finished before all reloads are done. Reftest / crashtest has no way to know it should expect for multiple reloads for a given test document otherwise.
Flags: needinfo?(sawang)
Comment on attachment 8888234 [details]
Bug 1381933 - Retry loading blank page if gClearingForAssertionCheck but load event comes from another URL.

https://reviewboard.mozilla.org/r/159184/#review164606

this looks like a good approach.  Do you want to modify some tests to use reftest-wait?  Please test on try with crashtest/reftest and retrigger a few times on all platforms.
Attachment #8888234 - Flags: review?(jmaher) → review+
:freesamael, can you try pushing again- I would like to have this bug resolved on Monday, even if we backout and work on the proper fix offline.
Whiteboard: [gfx-noted] → [gfx-noted][stockwell needswork]
(In reply to Samael Wang [:freesamael] from comment #11)
> Has reftest been so bad lately?
On WIndows, especially in the VMs: Yes.
(In reply to Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout) from comment #14)
> (In reply to Samael Wang [:freesamael] from comment #11)
> > Has reftest been so bad lately?
> On WIndows, especially in the VMs: Yes.

Made a try again, not seeing an obvious difference with / without the patch on Windows. I believe it's not introducing regression. Let's try to land this.
Keywords: checkin-needed
Pushed by cbook@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b756c4d0b7ff
Retry loading blank page if gClearingForAssertionCheck but load event comes from another URL. r=jmaher
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/b756c4d0b7ff
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
Duplicate of this bug: 1381839
Whiteboard: [gfx-noted][stockwell needswork] → [gfx-noted][stockwell fixed:other]
You need to log in before you can comment on or make changes to this bug.