Firefox does not respect remapped application short-cuts in MacOS

RESOLVED DUPLICATE of bug 1333781

Status

()

defect
RESOLVED DUPLICATE of bug 1333781
2 years ago
2 years ago

People

(Reporter: mark, Unassigned)

Tracking

10 Branch
x86_64
macOS
Points:
---

Firefox Tracking Flags

(firefox-esr52 affected, firefox55 affected, firefox56 affected, firefox57 affected)

Details

Reporter

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.115 Safari/537.36 OPR/46.0.2597.46

Steps to reproduce:

Remap keys in MacOS Sierra (10.12.5)

To remap:

1) System Preferences -> Keyboard -> Shortcuts
2) Select App Shortcuts -> + (Add)
3) Map Ctrl-c to Copy
           ctrl-v to paste

4) Start Firefox
5) Select text and press ctrl-c
6) Select text field and press ctrl-v




Actual results:

On ctrl-c:

- Edit menu flashes
- Text is *not* copied to clipboard

On ctrl-v:

- Edit menu flashes
- Clipboard is *not* copied to input buffer


Expected results:

On ctrl-c:

- Edit menu flashes
- Text is copied to clipboard

On ctrl-v:

- Edit menu flashes
- Clipboard is copied to input buffer
Component: Untriaged → Shell Integration
Shell integration has no shortcut code.
Component: Shell Integration → Untriaged
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170907220212

Hello,

I have tested this issue on latest Firefox (55.0.3), latest Nightly build(57.0a1) and managed to reproduce it. The text is correctly copied in the clipboard, but cannot be pasted using the shortcut. If you use the "Paste" option from context menu, the operation works properly.

I have also tested this issue on older Firefox versions, and the issue still reproduces on Firefox 10.
Status: UNCONFIRMED → NEW
Component: Untriaged → Keyboard: Navigation
Ever confirmed: true
OS: Unspecified → Mac OS X
Product: Firefox → Core
Hardware: Unspecified → x86_64
Looks a duplicate of bug 1216675.
Status: NEW → RESOLVED
Closed: 2 years ago
Component: Keyboard: Navigation → Widget: Cocoa
Resolution: --- → DUPLICATE
Version: 54 Branch → 10 Branch
Duplicate of bug: 1216675
Remapping built-in shortcuts is covered by bug 1333781.
Duplicate of bug: 1333781
You need to log in before you can comment on or make changes to this bug.