Closed Bug 1381997 Opened 3 years ago Closed 3 years ago

On Windows 7, preview of compacts theme is messy compared to real appearence

Categories

(Firefox :: Theme, defect, P1)

Unspecified
Windows 7
defect

Tracking

()

VERIFIED FIXED
Iteration:
57.3 - Sep 19
Tracking Status
firefox57 --- verified
firefox58 --- verified

People

(Reporter: clement.lefevre, Assigned: johannh)

References

(Blocks 1 open bug)

Details

(Keywords: nightly-community, Whiteboard: [reserve-photon-visual][mozfr-community][fixed by bug 1399498])

Attachments

(4 files)

On Windows 7, when hovering over both the clear or dark compact themes to preview them, they appear only as partial around tabs, using partly Aero while it isn't if they're really applied. See above screenshots to have a better understanding
Problem doesn't appear with others downloadable themes
Is this still reproducible? A lot has changed in Nightly since this was filed.
Flags: needinfo?(clement.lefevre)
(In reply to Justin Dolske [:Dolske] from comment #6)
> Is this still reproducible? A lot has changed in Nightly since this was
> filed.

Yes that's still the case: background of tab bar is half transparent and half blurry when in customize mode whil it's solid outside of customize mode. Which means that when user pick its theme, the preview is actually different compared to what he'll actually get.
Flags: needinfo?(clement.lefevre)
Blocks: photon-tabs
Whiteboard: [mozfr-community] → [photon-visual][triage][mozfr-community]
This sounds like a solid bug to me.
Priority: -- → P3
I'll fix this as part of bug 1399498.
Assignee: nobody → jhofmann
Status: NEW → ASSIGNED
Depends on: 1399498
Flags: qe-verify+
OS: Unspecified → Windows 7
Priority: P3 → P1
Whiteboard: [photon-visual][triage][mozfr-community] → [reserve-photon-visual][mozfr-community]
Iteration: --- → 57.3 - Sep 19
QA Contact: ovidiu.boca
Fixed by bug 1399498. Feel free to verify or re-open.
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Whiteboard: [reserve-photon-visual][mozfr-community] → [reserve-photon-visual][mozfr-community][fixed by bug 1399498]
(In reply to Johann Hofmann [:johannh] from comment #10)
> Fixed by bug 1399498. Feel free to verify or re-open.

Well, preview is now identical to result outside of the preview mode.
However this bug did result in changes in light and dark themes too with a mix between Aero and Firefox UI that seems… strange?
However I've no idea if this was the result you were looking for. So I'm wondering if I should open another bug for that.
(In reply to Clément Lefèvre from comment #11)
> (In reply to Johann Hofmann [:johannh] from comment #10)
> > Fixed by bug 1399498. Feel free to verify or re-open.
> 
> Well, preview is now identical to result outside of the preview mode.
> However this bug did result in changes in light and dark themes too with a
> mix between Aero and Firefox UI that seems… strange?
> However I've no idea if this was the result you were looking for. So I'm
> wondering if I should open another bug for that.

Not a bug if it looks like this: http://design.firefox.com/people/shorlander/photon/Mockups/windows-7.html

Feel free to open a bug otherwise.
I verified this issue using Nightly 58.0a1 and Firefox Beta 57.0b9 with Build ID 20171016185129 on Windows 7 x32. and I can confirm the fix.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.