Intermittent browser/components/preferences/in-content-new/tests/browser_applications_selection.js | Uncaught exception - Condition timed out: () =>

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
2 years ago
10 months ago

People

(Reporter: intermittent-bug-filer, Unassigned)

Tracking

({intermittent-failure})

unspecified
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox56 disabled, firefox57 affected)

Details

(Whiteboard: [stockwell disabled])

Attachments

(1 attachment)

Blocks: 1365133
After looking at the log, looks like the root cause is Bug 1381706.
Depends on: 1381706
looks like bug 1381706 is active, lets wait for that to be resolved
Whiteboard: [stockwell needswork]
(In reply to Joel Maher ( :jmaher) (UTC-9) from comment #3)
> looks like bug 1381706 is active, lets wait for that to be resolved

No recent activity in bug 1381706 - looks like that's delayed.

But nearly all failures here have been non-e10s; since we're not testing that configuration any more, this should become much less frequent.
Still an extremely frequent failure on Beta post-uplift, though.
Whiteboard: [stockwell needswork] → [stockwell unknown]
Any objections to disabling this test on Beta for affected platforms, Evan?
Flags: needinfo?(evan)
(In reply to Ryan VanderMeulen [:RyanVM] from comment #12)
> Any objections to disabling this test on Beta for affected platforms, Evan?

No, since we still haven't figured out the root cause on Bug 1381706 at this stage.

But I think we should also get feedback from Jared.

Hi Jared,

What do you think of Comment 12?
Flags: needinfo?(evan) → needinfo?(jaws)
I'm OK with disabling the test on Beta.
Flags: needinfo?(jaws)
Flags: needinfo?(ryanvm)
this has really increased in failures this week, all on linux debug:
https://brasstacks.mozilla.com/orangefactor/index.html?display=Bug&bugid=1382057


:jaws, could you help prioritize and find someone to own this?  Possibly we just skip this on linux if we feel the other platforms and configurations are adequate.
Flags: needinfo?(jaws)
Flags: needinfo?(jaws) → needinfo?(evan)
Flags: needinfo?(rchien)
According comment 1, it might be related to bug 1381706.

Evan, can you help take a look of this?
Flags: needinfo?(rchien)
(In reply to Joel Maher ( :jmaher) (UTC-5) from comment #19)
> Possibly we just skip this on linux if we feel the other platforms and configurations
> are adequate.

I think we could disable the test at this stage since Bug 1381706 still not fixed yet.
Flags: needinfo?(evan)
Attachment #8901740 - Flags: review?(gbrown) → review+
Pushed by jmaher@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/a849be991e6b
Disable browser/components/preferences/in-content-new/tests/browser_applications_selection.js on linux. r=gbrown
Keywords: leave-open
Whiteboard: [stockwell unknown] → [stockwell disabled]
Should be fixed on Nightly by bug 1381706.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.