Firefox Notes UI elements are wrongly displayed if installed using the Windows Registry Editor

RESOLVED DUPLICATE of bug 1380156

Status

RESOLVED DUPLICATE of bug 1380156
a year ago
3 months ago

People

(Reporter: emilpasca, Unassigned)

Tracking

56 Branch
x86_64
Windows

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8887884 [details]
notes_registry_issue.gif

[Notes]:
- When installing the snoozetabs add-on (which is also an webextension), using the Windows Registry Editor, the snoozetabs UI elements are also wrongly displayed.

[Affected versions]:
- Firefox 56.0a1
- Firefox Notes dev v1.5.1

[Affected Platforms]:
- All Windows

[Prerequisites]:
- Have the latest Firefox Notes add-on xpi (version 1.5.1 -dev, built on 07/18/2017) unpacked in a local folder.
- The pref "xpinstall.signatures.required" is set to "false".
- Have a string variable with the value name "notes@mozilla.com" and value data "C:\Users\username\Downloads\firefox_notes-1.5.1dev" (path to the add-on folder) under the "HKEY_LOCAL_MACHINE\SOFTWARE\Mozilla\Firefox\Extensions" registry folder. Details here: https://developer.mozilla.org/en-US/Add-ons/Adding_extensions_using_the_Windows_registry.

[Steps to reproduce]:
1. Open the browser with the profile from prerequisites.
2. Navigate to "about:addons" and click on the "Extensions" tab.
3. Enable "Firefox Notes".
4. Click on the "Show sidebars" toolbar button.
5. Click on the "Sidebar switcher" button and switch to "Notes".
6. Observe the "Notes" UI elements in the sidebar.
7. Resize the sidebar and observe elements behavior.

[Expected result]:
6. The "Notes" UI elements are correctly displayed.
7. The "Notes" UI elements doesn't suffer any changes.


[Actual result]:
6. The "Notes" UI elements are wrongly displayed.
7. The "Notes" UI elements are wrongly resized.

[Notes]:
[Additional Notes]:
- After enabling Firefox Notes addon, the following error message is displayed in the browser console:
"Use of getAttributeNode() is deprecated. Use getAttribute() instead. disco-b603698b56ba6b875983.js:1:634091
Use of Mutation Events is deprecated. Use MutationObserver instead.  quill.js:7:154006
Unknown localization message givefeedback"
- Attached a screen recording of the issue.

Refs: https://github.com/mozilla/notes/issues/156
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1380156
See Also: → bug 1385057

Updated

3 months ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.