Closed Bug 1382320 Opened 4 years ago Closed 4 years ago

Xpcshell IMAP test failure 2017-07-19

Categories

(Thunderbird :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 56.0

People

(Reporter: jorgk-bmo, Assigned: jorgk-bmo)

Details

(Whiteboard: [Thunderbird-testfailure: X all])

Attachments

(1 file)

TEST-UNEXPECTED-FAIL | mailnews/base/test/unit/test_imapPump.js | xpcshell return code: 0 [log…]
TEST-UNEXPECTED-FAIL | mailnews/imap/test/unit/test_imapMove.js | xpcshell return code: 0 [log…]
TEST-UNEXPECTED-FAIL | mailnews/imap/test/unit/test_filterNeedsBody.js | xpcshell return code: 0 [log…]
TEST-UNEXPECTED-FAIL | mailnews/imap/test/unit/test_downloadOffline.js | xpcshell return code: 0 [log…]
TEST-UNEXPECTED-FAIL | mailnews/imap/test/unit/test_offlineCopy.js | xpcshell return code: 0 [log…]
TEST-UNEXPECTED-FAIL | mailnews/imap/test/unit/test_cacheParts.js | xpcshell return code: 0 [log…]
TEST-UNEXPECTED-FAIL | mailnews/imap/test/unit/test_downloadOffline.js | xpcshell return code: 0 [log…]
TEST-UNEXPECTED-FAIL | mailnews/imap/test/unit/test_filterNeedsBody.js | xpcshell return code: 0 [log…]
TEST-UNEXPECTED-FAIL | mailnews/imap/test/unit/test_imapMove.js | xpcshell return code: 0 [log…]
TEST-UNEXPECTED-FAIL | mailnews/imap/test/unit/test_offlineCopy.js | xpcshell return code: 0 [log…]

20 Errors:
"CONSOLE_MESSAGE: (warn) [JavaScript Warning: "TypeError: can't assign to properties of (new Number(2)): not an object" {file: "C:\\slave\\test\\build\\tests\\xpcshell\\head.js" line: 1383}]"

M-C: last good: 1b065ffd8a535a0ad4c39a912af18e948e
M-C: first bad: a1ea69a3a0a760036e047f6ff89897aa7f

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=1b065ffd8a535a0ad4c39a912af18e948e&tochange=a1ea69a3a0a760036e047f6ff89897aa7f

I can't see where this failure is coming from, I'll have to try on a local build.

Aria, can you spot the problem, seem like something JS-related.
Flags: needinfo?(arai.unmht)
Or maybe a removed preference? From a debug log:
INFO -  PID 7696 | [7696] WARNING: NS_ENSURE_TRUE(aObserver) failed: file c:/builds/moz2_slave/tb-c-cen-w32-d-000000000000000/build/mozilla/modules/libpref/nsPrefBranch.cpp, line 748
INFO -  PID 7696 | [7696] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80070057: file c:/builds/moz2_slave/tb-c-cen-w32-d-000000000000000/build/mozilla/modules/libpref/Preferences.cpp, line 1924

0x80070057 = NS_ERROR_ILLEGAL_VALUE
Looks like this is related to bug 1380470.

All the tests that fail use |tests.forEach(add_task);|
https://dxr.mozilla.org/comm-central/search?q=tests.forEach(add_task)%3B&redirect=false

testing/xpcshell/head.jshead.js#544 which appears in the error log
c:\mozilla-source\comm-central\mozilla\testing\xpcshell\head.js:_do_main:223
c:\mozilla-source\comm-central\mozilla\testing\xpcshell\head.js:_execute_test:544
is run_test();

Mike, Andrew, do you have any indication why our tests fail now?
Flags: needinfo?(mdeboer)
Flags: needinfo?(arai.unmht)
Flags: needinfo?(ahalberstadt)
Hmm, looks like our scheme

var tests = [
  setup,
  ...
];

function* setup() {
  // No offline download, otherwise nothing is cached.
  Services.prefs.setBoolPref("mail.server.server1.offline_download", false);
  ...
}

function run_test() {
  tests.forEach(add_task);
  run_next_test();
}

doesn't work any more.
> function add_test(properties, func = properties, isTask = false) {

now the add_test function expects the 2nd and 3rd parameters to be meaningful value.
so we shouldn't use forEach directly, that passes index as 2nd parameter, and array as 3rd parameter.

|tests.forEach(x => add_task(x))| would work.
oops, the explanation about 3rd parameter was wrong.

> function add_task(properties, func = properties) {
>   return add_test(properties, func, true);
> }

the issue is only about 2nd parameter.
OK, thanks, I'll try that.
Flags: needinfo?(mdeboer)
Flags: needinfo?(ahalberstadt)
This works, thanks, Arai!
Assignee: nobody → jorgk
Status: NEW → ASSIGNED
https://hg.mozilla.org/comm-central/rev/2501146ba1d4b835df72dff6c15efe6a7d18dcdb
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 56.0
You need to log in before you can comment on or make changes to this bug.