Closed Bug 1382358 Opened 2 years ago Closed 2 years ago

We crash if the (bad?) driver gives an unrecognized shader version for some reason

Categories

(Core :: Canvas: WebGL, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla56
Tracking Status
firefox-esr52 --- fixed
firefox56 --- fixed

People

(Reporter: jgilbert, Assigned: jgilbert)

References

Details

(Whiteboard: gfx-noted)

Attachments

(1 file)

We should just return a safe default instead.
Comment on attachment 8888047 [details]
Bug 1382358 - Allow unusual/spurious glsl versions in non-DEBUG builds. -

https://reviewboard.mozilla.org/r/158912/#review164338
Attachment #8888047 - Flags: review?(kvark) → review+
Pushed by jgilbert@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/4a5185552a07
Allow unusual/spurious glsl versions in non-DEBUG builds. - r=kvark
https://hg.mozilla.org/mozilla-central/rev/4a5185552a07
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
Could this be uplifted for the next ESR? The latest Nvidia driver update seems to crash both Firefox ESR 52 and SeaMonkey 2.49.1. 

I only have a crash report for 2.49.1 based on ESR 52.4:

https://crash-stats.mozilla.com/report/index/ffa42b4e-0df2-4e60-928a-9189d0171129

According to the discussion in bug 1421093 it also affects Firefox 52 in Gentoo.
Flags: needinfo?(jgilbert)
Comment on attachment 8888047 [details]
Bug 1382358 - Allow unusual/spurious glsl versions in non-DEBUG builds. -

[Approval Request Comment]
If this is not a sec:{high,crit} bug, please state case for ESR consideration: Crashes on up-to-date graphics drivers.
User impact if declined: Crashes for users with webgl.
Fix Landed on Version: 56
Risk to taking this patch (and alternatives if risky): Minimal
String or UUID changes made by this patch: none

See https://wiki.mozilla.org/Release_Management/ESR_Landing_Process for more info.
Flags: needinfo?(jgilbert)
Attachment #8888047 - Flags: approval-mozilla-esr52?
Comment on attachment 8888047 [details]
Bug 1382358 - Allow unusual/spurious glsl versions in non-DEBUG builds. -

WebGL crash fix, ESR52+
Attachment #8888047 - Flags: approval-mozilla-esr52? → approval-mozilla-esr52+
Duplicate of this bug: 1421093
(In reply to Ryan VanderMeulen [:RyanVM] from comment #8)
> https://hg.mozilla.org/releases/mozilla-esr52/rev/762f4e53889a

Even though the above patch shows a target "milestone 52.5.3", the issue is still present in (at least) the 64-bit Linux version of 52.5.3 ESR. Can you please take care of integrating this fix into all ESR releases as soon as possible?

The issue indeed is a P1, as it makes Firefox reproducibly crash the current tab every time with the 387.x NVidia drivers e.g. when accessing Google Maps.

Many thanks!
awl
(In reply to awl1 from comment #10)
> (In reply to Ryan VanderMeulen [:RyanVM] from comment #8)
> > https://hg.mozilla.org/releases/mozilla-esr52/rev/762f4e53889a
> 
> Even though the above patch shows a target "milestone 52.5.3", the issue is
> still present in (at least) the 64-bit Linux version of 52.5.3 ESR. Can you
> please take care of integrating this fix into all ESR releases as soon as
> possible?
> 
> The issue indeed is a P1, as it makes Firefox reproducibly crash the current
> tab every time with the 387.x NVidia drivers e.g. when accessing Google Maps.
> 
> Many thanks!
> awl

Please link to a crash report.
Flags: needinfo?(awl1)
(In reply to Jeff Gilbert [:jgilbert] from comment #11)
> (In reply to awl1 from comment #10)
> > (In reply to Ryan VanderMeulen [:RyanVM] from comment #8)
> > > https://hg.mozilla.org/releases/mozilla-esr52/rev/762f4e53889a
> > 
> > Even though the above patch shows a target "milestone 52.5.3", the issue is
> > still present in (at least) the 64-bit Linux version of 52.5.3 ESR. Can you
> > please take care of integrating this fix into all ESR releases as soon as
> > possible?
> > 
> > The issue indeed is a P1, as it makes Firefox reproducibly crash the current
> > tab every time with the 387.x NVidia drivers e.g. when accessing Google Maps.
> > 
> > Many thanks!
> > awl
> 
> Please link to a crash report.

Sorry - here you are:

https://crash-stats.mozilla.com/report/index/c46bd516-06d7-4ef1-bf1d-d1e350180107
https://crash-stats.mozilla.com/report/index/7e22ffb8-38ea-458e-95a3-6951d0180106
https://crash-stats.mozilla.com/report/index/aec50c2f-d61e-4746-ac58-8d8bc0180103

HTH & best regards
awl
Flags: needinfo?(awl1)
The file was updated but looking at the tags with TortoiseHg it seems only Bug 1424373 was incorporated in 52.5.3 ESR compared to 52.5.2.
This is indeed fixed in esr52 top of tree. It may not have hit release channel, but it's fixed as far as this bug is concerned.
(In reply to Jeff Gilbert [:jgilbert] from comment #14)
> This is indeed fixed in esr52 top of tree. It may not have hit release
> channel, but it's fixed as far as this bug is concerned.

It is fine that this issue is fixed in the ESR 52 source code "top of tree", but please still make sure that it ends up in the ESR release channel - otherwise the fix is worth nothing for all ESR end users... :-(

If there is a need to ping any specific person/team (release management?) to notify them of this oversight, please let them konw such that the fix can be incorporated into a new ESR release asap.

Many thanks,
awl
(In reply to awl1 from comment #15)
> (In reply to Jeff Gilbert [:jgilbert] from comment #14)
> > This is indeed fixed in esr52 top of tree. It may not have hit release
> > channel, but it's fixed as far as this bug is concerned.
> 
> It is fine that this issue is fixed in the ESR 52 source code "top of tree",
> but please still make sure that it ends up in the ESR release channel -
> otherwise the fix is worth nothing for all ESR end users... :-(
> 
> If there is a need to ping any specific person/team (release management?) to
> notify them of this oversight, please let them konw such that the fix can be
> incorporated into a new ESR release asap.
> 
> Many thanks,
> awl

It's all on-track. The concern is appreciated.
(In reply to Jeff Gilbert [:jgilbert] from comment #16)
> It's all on-track. The concern is appreciated.

Many thanks Jeff. Is there any ETA for the next ESR release that will contain the fix?
If we spin a new chemspill for 52.5, it'll be in there. Otherwise, it'll be released with esr52.6 on Jan23[1].

[1]: https://wiki.mozilla.org/RapidRelease/Calendar
You need to log in before you can comment on or make changes to this bug.