flash of white when opening new tab page

RESOLVED DUPLICATE of bug 1379587

Status

()

Firefox
Activity Streams: Newtab
RESOLVED DUPLICATE of bug 1379587
7 months ago
6 months ago

People

(Reporter: asa, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox57 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 months ago
In the latest nightly I get a flash of white before the search and tiles are displayed when opening a new tab. I don't recall seeing this flash with the old new tab page. 

Steps to reproduce:

1. Have a new tab open
2. Open another new tab

Results: see a flash of white while the new tab loads up before the search and tiles are displayed.

Expected results: no flash of white. The new tab should load with its content already visible.

Tested with latest nightly on Win10
Nightly went from original new tab to compact tiles new tab and back to the original new tab. See bug 1379860. By latest you mean the original new tab? That shouldn't be a recent regression since nothing has changed on it. Could you confirm you which new tab you are talking about?
Flags: needinfo?(asa)
(Reporter)

Comment 2

7 months ago
This is with the new New Tab page (Activity Stream).
Flags: needinfo?(asa)
OK. Activity Stream is not on Nightly by default.

ni Tim go get this moved to Activity Stream instead.
Flags: needinfo?(tspurway)

Updated

7 months ago
Component: New Tab Page → Activity Streams: Application Servers
Flags: needinfo?(tspurway)

Updated

7 months ago
Component: Activity Streams: Application Servers → Activity Streams: Newtab

Comment 4

6 months ago
Not sure if it matters, but even with with search, top sites, and Recommended by Pocket options turned off, the flash is still apparent. Tested the latest nightly on Ubuntu 16.04 (no problems with the old new tab page in Firefox 56.0b2).

Comment 5

6 months ago
Created attachment 8896506 [details]
green tabpanels and many new tabs

billm: Could this be related to bug 1132072? Where about:newtab is now in content process and isn't immediately switched to upon new tab (maybe)?

It looks like the xul:tabpanels is being shown, and can be tested with:

gBrowser.mPanelContainer.style.backgroundColor = "green";

I suppose one hack is to just make that background color the same as what would be on about:newtab…
Flags: needinfo?(wmccloskey)

Comment 6

6 months ago
Actually, the white is coming from browser.display.background_color pref default of #ffffff:

https://searchfox.org/mozilla-central/source/browser/base/content/tabbrowser.xml#5496-5499

dao, any suggestions on how to approach this?

Do we just set that pref's value to Photon's Grey 10? (Activity Stream will be updating its background to Grey 10 soon. See https://github.com/mozilla/activity-stream/issues/2979#issuecomment-320752977 )
Flags: needinfo?(dao+bmo)

Comment 7

6 months ago
This only happens when quickly opening a second new tab before it could be preloaded, right? That sounds like a rather constructed test case, not something we should optimize for. The default background color is relevant not only to the new tab page but also to web pages that aren't going to use the photon color palette...
Flags: needinfo?(dao+bmo)

Comment 8

6 months ago
This happens every single time a new tab is opened, not just when several are opened in quick succession (if that was the implication?).
This sounds like it might be our optimization for showing "white" when switching to a tab that's in the process of loading. I can't remember the bug number for that.
Flags: needinfo?(wmccloskey) → needinfo?(mconley)
(In reply to Aibara Iduas from comment #8)
> This happens every single time a new tab is opened, not just when several
> are opened in quick succession (if that was the implication?).

This shouldn't happen since this page is preloaded.

That delay seems to be the real problem here, not the default browser background which I don't think we'll change.

Updated

6 months ago
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Flags: needinfo?(mconley)
Resolution: --- → DUPLICATE
Duplicate of bug: 1379587
You need to log in before you can comment on or make changes to this bug.