Intermittent toolkit/components/places/tests/browser/browser_visited_notfound.js | Uncaught exception - at resource://testing-common/PlacesTestUtils.jsm:222 - TypeError: rows[0] is undefined

RESOLVED FIXED in Firefox 56

Status

()

defect
P1
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: intermittent-bug-filer, Assigned: standard8)

Tracking

({intermittent-failure})

unspecified
mozilla56
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox56 fixed)

Details

(Whiteboard: [fxsearch][stockwell fixed:other])

Attachments

(1 attachment)

Okay, this has instances before the merge from m-c to autoland this morning.
Comment hidden (Intermittent Failures Robot)
::mak, this has a lot of failures!  I suspect many of these are retriggered jobs- could you look into this?
Flags: needinfo?(mak77)
Whiteboard: [stockwell needswork]
Looking at the regression range from Wes, it seems it is definitely bug 1381049 that caused this. This will be my #1 job today - worst case we can possibly back it out, but I'd like to at least take a look first.
Assignee: nobody → standard8
Blocks: 1381049
Flags: needinfo?(mak77)
Priority: -- → P1
Whiteboard: [stockwell needswork] → [stockwell needswork][fxsearch]

Comment 8

2 years ago
mozreview-review
Comment on attachment 8888273 [details]
Bug 1382444 - Stop places maintenance running during tests to avoid unnecessary overhead and intermittent issues.

https://reviewboard.mozilla.org/r/159214/#review164604

Thank you!

::: testing/profiles/prefs_general.js:384
(Diff revision 1)
>  user_pref("marionette.prefs.recommended", false);
>  
>  // Disable Screenshots by default for now
>  user_pref("extensions.screenshots.system-disabled", true);
> +
> +user_pref("places.database.lastMaintenance", 7258114800);

Please add a brief comment above explaining what this does and why.
Attachment #8888273 - Flags: review?(mak77) → review+
After some investigations, we've determined that it appears to be the PlacesDBUtils.jsm changes from bug 1381049 that are causing this & a lot of other intermittents.

The tests are writing a visit to the database using the read-write connection to the DB, and are then using a separate read-only connection to read the DB. However, if the write hasn't finished, then the read-only connection will get the previous snapshot.

The changes in PlacesDBUtils.jsm are causing the writes to behave slightly differently, and what we are seeing is that the places maintenance task is sometimes kicking in and causing the writes to take much longer. This then causes the intermittent issues in the tests.

Hence we've decided to turn off the maintenance task for tests - it doesn't need to run for them anyway.
Comment hidden (mozreview-request)

Comment 12

2 years ago
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1cfc47df313b
Stop places maintenance running during tests to avoid unnecessary overhead and intermittent issues. r=mak
Comment hidden (Intermittent Failures Robot)
https://hg.mozilla.org/mozilla-central/rev/1cfc47df313b
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
Comment hidden (Intermittent Failures Robot)
thanks for fixing this- should we consider this for talos/perf tests as well?
Whiteboard: [stockwell needswork][fxsearch] → [fxsearch][stockwell fixed:other]
(In reply to Joel Maher ( :jmaher) (UTC-8) from comment #16)
> thanks for fixing this- should we consider this for talos/perf tests as well?

It could make sense considered this code runs once a week in a normal profile. But maybe in general the idle service should not fire idle-daily on Talos and that may solve more issues than just one.
Though, to do that, we'd need to set idle.lastDailyNotification to now (in seconds) and I don't know if that's feasible.
Regardless, it's worth a separate bug for Talos.
good idea, I filed bug 1383896
Comment hidden (Intermittent Failures Robot)
No longer blocks: 1382496
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
this failure has come back, 25 instances in the last week:
https://brasstacks.mozilla.com/orangefactor/index.html?display=Bug&bugid=1382444

all on linux64-debug.

:standard8, do you think there is something easy to do here, or it would require a bit more investigation?
Flags: needinfo?(standard8)
Comment hidden (Intermittent Failures Robot)
(In reply to Joel Maher ( :jmaher) (UTC-5) from comment #23)
> this failure has come back, 25 instances in the last week:
> https://brasstacks.mozilla.com/orangefactor/index.
> html?display=Bug&bugid=1382444
> 
> all on linux64-debug.
> 
> :standard8, do you think there is something easy to do here, or it would
> require a bit more investigation?

It looks like it was never quite 100% fixed. The interesting thing is I can't find any related bugs being marked as fixed from when it started ramping up again.

That makes me think it is something else that could have affected timing or something else. Probably worth filing a new bug and we'll think about it there.
Flags: needinfo?(standard8)
Comment hidden (Intermittent Failures Robot)
Depends on: 1424030
You need to log in before you can comment on or make changes to this bug.