Intermittent dom/canvas/test/webgl-conf/generated/test_2_conformance2__textures__misc__texture-npot.html | POT texture with TEXTURE_MIN_FILTER set to LINEAR_MIPMAP_LINEAR should draw.

RESOLVED FIXED

Status

()

P3
normal
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: intermittent-bug-filer, Assigned: svargas)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted])

Priority: -- → P3
Whiteboard: [gfx-noted]
Sam, if there is nothing higher priority, can you take a look?
Assignee: nobody → svargas
(Assignee)

Comment 2

a year ago
Sure I'll look into it.
1 failures in 822 pushes (0.001 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* mozilla-inbound: 1

Platform breakdown:
* osx-10-10: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1382481&startday=2017-07-17&endday=2017-07-23&tree=all
(Assignee)

Comment 4

a year ago
Progress Update:

I've narrowed the problem down to the ValidateAndInitAttachments() function in
WebGLFramebuffer.cpp:893

The failing test calls getError() (which returns OK), texParameteri(),
clearColor(), clear(), and then drawArrays(), and then getError() again which
returns INVALID_FRAMEBUFFER_OPERATION

clear() and drawArrays() are the only functions that call ValidateAndInit
Attachments(), this is the only function that could have been called in
this context that would trigger the INVALID_FRAMEBUFFER_OPERATION return
value.

When I try to reproduce the bug with a more recent revision of the code
I couldn't get it to reoccur. (https://treeherder.mozilla.org/#/jobs?repo=try&revision=4bf6818f7a649bb221a5e9b6404d4b20acb26kk073).

The good news is that I've been able to reproduce it on Try for OS X with the
commit ' Bug 1381854 - FlyWeb events must mark the Response as BodyUsed, r=djvj
' (SHA 3283dc07e98bf02473), the same one in the original fail try. The problem
happens in the optimized version but the debug version times out before it can
get to that point.

Reproduced failure:

(https://treeherder.mozilla.org/#/jobs?repo=try&revision=595241bb813b199f134de1407d88b1f2af5e3490&selectedJob=117103208)
(Assignee)

Comment 5

a year ago
Figured it out! This failure was caused by Bug 1382104, which was backed out
immediately after this changeset was pushed to try. I verified it using hg
bisect.  It explains why the failure occurred on every retrigger at this commit
but not prior to Bug 1382104 or after it's back out.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.