Intermittent TEST-UNEXPECTED-TIMEOUT | image/test/mochitest/test_webcam.html | application timed out after 330 seconds with no output

RESOLVED FIXED in Firefox 56

Status

()

defect
P3
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: intermittent-bug-filer, Assigned: aosmond)

Tracking

({intermittent-failure})

unspecified
mozilla56
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox56 fixed)

Details

(Whiteboard: [gfx-noted])

Attachments

(1 attachment)

Whiteboard: [gfx-noted]
This is fallout from bug 1359833. There is an assertion before the timeout:
> Assertion failure: mListener, at z:/build/build/src/image/imgRequestProxy.cpp:293
Blocks: 1359833
Flags: needinfo?(aosmond)
I see what the problem is. The assert is wrong in this context, so thankfully release builds are fine.
Assignee: nobody → aosmond
Status: NEW → ASSIGNED
Flags: needinfo?(aosmond)
Priority: -- → P3
Pushed by aosmond@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/760368896800
Fix assert in imgRequestProxy::Dispatch to accept a listener or a tab group. r=me
https://hg.mozilla.org/mozilla-central/rev/760368896800
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
You need to log in before you can comment on or make changes to this bug.