Closed Bug 1382575 Opened 7 years ago Closed 6 years ago

Fix 7 tests failures on devtools/client/aboutdebugging due the EventEmitter refactoring

Categories

(DevTools :: about:debugging, enhancement, P2)

enhancement

Tracking

(firefox57 fix-optional)

RESOLVED DUPLICATE of bug 1384546
Tracking Status
firefox57 --- fix-optional

People

(Reporter: zer0, Unassigned)

References

Details

Failing tests:

devtools/client/aboutdebugging/test/browser_addons_debug_info.js
devtools/client/aboutdebugging/test/browser_addons_debug_webextension_popup.js
devtools/client/aboutdebugging/test/browser_addons_debugging_initial_state.js
devtools/client/aboutdebugging/test/browser_addons_install.js
devtools/client/aboutdebugging/test/browser_addons_reload.js
devtools/client/aboutdebugging/test/browser_addons_remove.js
devtools/client/aboutdebugging/test/browser_addons_toggle_debug.js

The refactoring is currently only on:

https://github.com/zer0/gecko/tree/event-emitter-1381542

We need to address the test failures before land this patch in m-c.
Here the original try build with the failures:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=bba13e27a2371fa8aad68b9b227534b31829cb0d

Those failures are most likely due the breaking change in how the `EventEmitter` emits event.

Previously, the first argument was the event type:

  myEmitter.on("custom-event", (eventType, message) => { ... });

Now the first argument is the message:

  myEmitter.on("custom-event", (message) => { ... });

In the majority of the scenario the `eventType` is ignored by our code, so we should just remove it from the function's signature.

For more details and edge cases, see: https://github.com/devtools-html/snippets-for-removing-the-sdk/#events
Flags: qe-verify-
Priority: -- → P2
No longer blocks: 1381542
Blocks: 1384546
Whiteboard: [nosdk]
Component: Developer Tools → Developer Tools: about:debugging
Since this doesn't have an event emitter itself, it is likely that the issues this component had were resolved in other refactorings. We should be able to safely close this!
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.