{css} Thin apprunner or view causes non-animation or no background colour

VERIFIED INVALID

Status

()

defect
P3
normal
VERIFIED INVALID
20 years ago
20 years ago

People

(Reporter: filc_lists, Assigned: troy)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

STEPS TO REPRODUCE

Open apprunner or viewer, with url "resource:/res/samples/test1.html" with the
window is less than the width of the longest <pre> line (list-style: square
outside url(resource:/res/gear1.gif); ) in my case 200 pixels wide is small
enough.

ACTUAL RESULTS

1. The grey background of the <pre> box is fixed to the width of the visible
window, not the scrollable window.  If the horizontal scrollbar is dragged to
the right the background behind the <pre> text turns white.
2. The right of the background animated image at the bottom of the page
sometimes redraws statically, sometimes not at all depending on how
slowly/quickly the horizontal scrollbar is dragged right/left.

EXPECTED RESULTS

1. The grey background behind the <pre> box to extend to the right of the page
when fully scrolled to the right.
2. The animated background to be consistently animated when scrolled to the
right of the page.

BUILD DATE & PLATFORM

Linux 2.2.11, i686, Built from CVS 13/Sept/99 both Apprunner & Viewer.
Previously tested (circa 01/Sept/99) with M8 & M9 on Win95.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → INVALID
This is one of those cases where Gecko is doing the correct thing, but none of
the other browsers implement this properly so it appears to be a bug in Gecko

The issue is how the CSS2 'overflow' property works. The default is 'visible'
which means that content that overflows should be visible. However, the parent
element's box is _not_ expanded.

That's why you see the overflow content being displayed, but you don't see the
background color displayed in the overflow area
Thanks troy, that explains part one of the bug with the <pre> box, but it does
not explain why the animated background image at the bottom of the page should
sometimes redraw statically, and sometimes not redraw.  Should this bug
be-reopened?
File a separate bug for that problem, please. That probably isn't a layout bug,
and it's best to have only one problem per bug report.

Go ahead and assign the new bug to me, I'll reassign it
Status: RESOLVED → VERIFIED
Based on Troy's comments, marking as verified invalid.
You need to log in before you can comment on or make changes to this bug.