Keyboard and mouse zoom do not behave consistently in extension sidebars

REOPENED
Unassigned

Status

WebExtensions
General
P5
normal
REOPENED
a year ago
a month ago

People

(Reporter: emilpasca, Unassigned)

Tracking

({regression})

56 Branch
x86_64
Windows
regression

Firefox Tracking Flags

(firefox54 unaffected, firefox55 unaffected, firefox56 fix-optional)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8888300 [details]
notes_ctrl_scrolling.gif

[Affected versions]:
- Firefox 56.0a1, Build ID: 20170719030206
- Firefox Notes dev v1.5.1

[Affected Platforms]:
- All Windows

[Prerequisites]:
- Have a Firefox profile with the latest Firefox Notes add-on version (1.5.1 -dev, built on 07/20/2017) installed.

[Steps to reproduce]:
1. Open the browser with the profile from prerequisites.
2. Hover the "Notes" sidebar.
3. Holding the "Ctrl" key down, scroll up/down using the mouse wheel.
4. Observe the "Notes" UI elements and content.

[Expected result]:
- The "Notes" UI elements and content doesn't suffer any changes.

[Actual result]:
- The "Notes" UI elements and content are zoomed in/out.

[Regression]:
With Nightly 56.0a1, Build ID: 20170710030203, the issue is not reproducible.
Last good revision: 392ed89ec2730a48d10b1cec741e86a242d28aa3
First bad revision: a625a2e9b3333a8e76982ea65f077cfded6ac224
Pushlog: https://goo.gl/e9m7Ei

[Notes]:
- When using the keyboard shortcuts "Ctrl +/-" the webapage is correctly zoomed in/out and not the sidebar content and UI.
- Attached a screen recording of the issue.

Refs: https://github.com/mozilla/notes/issues/163

Kris, can you please have a look at this?

Comment 1

a year ago
This is because notes is in the sidebar it's HTML and has zoom support. So at this point its expected, are you suggesting we deliberately prevent it?
This is the expected behavior.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
(Reporter)

Comment 3

a year ago
I'm not against this, I find it quite useful for this specific experiment. But if we consider this as expected, then we should assure a certain level of consistency. Right now we are seeing the next issues:
- The zoom level of the sidebar cannot be actioned by keyboard shortcuts "Ctrl +/-" to zoom in/out and "Ctrl+0" to reset the zoom level. Instead, if the sidebar is focused and the CTRL +/- combination is pressed, the zoom is wrongly applied to the page.
- On Mac OS and Linux the zoom level of the sidebar cannot be performed at all.
Shouldn't this be possible on all platforms and channels?
- The zoom level of the sidebar can only be performed on Nightly. On Beta and Release channels this is not possible at the moment.
Flags: needinfo?(kmaglione+bmo)
Flags: needinfo?(amckay)

Comment 4

a year ago
Ctrl and mouse scroll zooms the sidebar on beta and release for me.

Ctrl +/- zooms the content not the sidebar.

I would probably move the bug into Firefox though because the WebExtension API is just opening a HTML sidebar and the keyboard shortcut in Firefox is not bound to the focused area.
Flags: needinfo?(amckay)
(In reply to Emil Pasca [:emilpasca], Desktop Engineering QA (on PTO 24/07 - 04/08)) from comment #3)
> - The zoom level of the sidebar cannot be actioned by keyboard shortcuts
> "Ctrl +/-" to zoom in/out and "Ctrl+0" to reset the zoom level. Instead, if
> the sidebar is focused and the CTRL +/- combination is pressed, the zoom is
> wrongly applied to the page.

That's a fair point. I suppose that should be fixed.

> - On Mac OS and Linux the zoom level of the sidebar cannot be performed at
> all.

That's because they Linux and OS-X currently use in-process browsers for sidebars, but the behavior will be consistent when all platforms use OOP extensions.
Status: RESOLVED → REOPENED
Flags: needinfo?(kmaglione+bmo)
Resolution: INVALID → ---
Summary: [Firefox Notes] Sidebar UI elements and content are zoomed in/out when holding the "Ctrl" key down and scrolling up/down using the mouse wheel → Keyboard and mouse zoom do not behave consistently in extension sidebars
Kris, should this be a priority to fix and if so, can you help find an owner for the bug?
Flags: needinfo?(kmaglione+bmo)
(In reply to Liz Henry (:lizzard) (needinfo? me) from comment #6)
> Kris, should this be a priority to fix and if so, can you help find an owner
> for the bug?

s/Kris/Andy/
Flags: needinfo?(kmaglione+bmo) → needinfo?(amckay)

Comment 8

a year ago
It's not a high priority.
Flags: needinfo?(amckay)
Priority: -- → P5
Thanks Andy!
status-firefox56: affected → fix-optional

Updated

a month ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.