[FTL] Machinery should provide suggestions based on the actual content

RESOLVED FIXED

Status

Webtools
Pontoon
P3
normal
RESOLVED FIXED
9 months ago
15 days ago

People

(Reporter: flod, Assigned: mathjazz)

Tracking

Trunk

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 months ago
Created attachment 8888328 [details]
share_matches.png

shotPageShareButton
    .title = Share

When I'm translating the title attribute, I expect Pontoon to give me translation memory matches for "Share", instead it tries to find matches for the whole construct (finding none).
(Assignee)

Updated

9 months ago
Duplicate of this bug: 1382349
(Assignee)

Comment 2

9 months ago
We need to figure out what to do when strings contain multiple values, i.e. attributes, selectors and also values in FTL sense.
Priority: -- → P3
(Assignee)

Updated

9 months ago
Summary: [FTL] Machinery should provide suggestions based on the attribute content → [FTL] Machinery should provide suggestions based on the actual content
(Assignee)

Comment 3

4 months ago
This particular case has been fixed as part of bug 1392255.

We still need to figure out how to use machinery with more complex strings (multiple attributes, value + attributes, plural and other multiple variants etc.). Currently we only send the first attribute or variant to Machinery.
(Assignee)

Comment 4

15 days ago
Marking as fixed in filing bug 1453341 for complex strings.
Assignee: nobody → m
Status: NEW → RESOLVED
Last Resolved: 15 days ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.