Closed Bug 1382767 Opened 4 years ago Closed 4 years ago

Some Twitter avatar images shift up and down while scrolling the page

Categories

(Core :: Graphics, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla56
Tracking Status
firefox-esr52 --- unaffected
firefox54 --- unaffected
firefox55 --- unaffected
firefox56 --- verified

People

(Reporter: cpeterson, Assigned: dvander)

References

()

Details

(Keywords: regression)

@ Jonathan, could this bug be a regression from your fix for ProcessRestyledFrames bug 1378219?

STR:
1. Load this series of tweets: https://twitter.com/pablohidalgo/status/888090530420322305
2. Wait for the page to finish loading.
3. Slowly scroll down the page.
4. Watch the tweets' avatar images.

RESULT:
About one-third of way down the page, the avatar images (starting with user "BOB") start shift up and down. Some have black graphics artifacts.

I think this is a recent regression in Nightly 56, but I had a hard time finding a regression range with mozregression. This is a possible regression range:

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=dece50457378ac4934afe9fb3c2a8054e8894588&tochange=0985725c848ec0cfc6f2f3c3a5aa3d71321e7620
(In reply to Chris Peterson [:cpeterson] from comment #0)
> @ Jonathan, could this bug be a regression from your fix for
> ProcessRestyledFrames bug 1378219?

I can't seem to reproduce the problem described (with latest Nightly on OS X), but I'd be surprised if it were a result of bug 1378219. Particularly with the mention of "black graphics artifacts", it sounds to me more like an issue in gfx-land than layout-land.
Chris, possibly dupe of 1305744?
Flags: needinfo?(cpeterson)
See Also: → 1305744
(In reply to Mike Taylor [:miketaylr] (55 Regression Engineering Owner) from comment #2)
> Chris, possibly dupe of 1305744?

I don't think this is a dupe of bug 1305744. That bug shows the user's own large avatar image scrolling at a different speed than the page, but the problem I see is black graphics glitches in the small avatar images on other users' tweets.
Flags: needinfo?(cpeterson)
Gotcha, thanks.
See Also: 1305744
I wonder if the bug is related to Bug 1381666.
:cpeterson, how do you think about comment 5?
Flags: needinfo?(cpeterson)
Good catch. I think this bug is probably the same issue as bug 1381666. I will retest after 1381666 is fixed.
Depends on: 1381666
Flags: needinfo?(cpeterson)
Bug 1381666 is fixed in the latest nightly.  Does this still happen?
Flags: needinfo?(cpeterson)
(In reply to Milan Sreckovic [:milan] from comment #8)
> Bug 1381666 is fixed in the latest nightly.  Does this still happen?

Nope. This bug is fixed!
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(cpeterson)
Resolution: --- → FIXED
Assignee: nobody → dvander
Target Milestone: --- → mozilla56
You need to log in before you can comment on or make changes to this bug.