Crash when trying to send ~2 GiB data channel messages

REOPENED
Unassigned

Status

()

P3
normal
Rank:
23
REOPENED
a year ago
2 months ago

People

(Reporter: lennart.grahl, Unassigned)

Tracking

({crash, testcase})

54 Branch
crash, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.86 Safari/537.36 OPR/46.0.2597.19 (Edition beta)

Steps to reproduce:

1. Open https://mozilla.github.io/webrtc-landing/data_test.html
2. Click on 'Start'
3. Open the console and type `dc1.send(new Uint8Array(2147483638))`


Actual results:

Crash (log references to https://searchfox.org/mozilla-central/source/xpcom/string/nsTSubstring.cpp#26).


Expected results:

Not crashing. :)
Confirmed.
Status: UNCONFIRMED → NEW
Rank: 16
Component: Untriaged → WebRTC
Ever confirmed: true
OS: Unspecified → All
Priority: -- → P1
Product: Firefox → Core
Hardware: Unspecified → All
Version: 55 Branch → 54 Branch
Crash Signature: [@ nsDOMDataChannel::Send ]
Rank: 16 → 23
Priority: P1 → P2
Mass change P2->P3 to align with new Mozilla triage process.
Priority: P2 → P3
Closing because no crash reported since 12 weeks.
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → WONTFIX
(Reporter)

Comment 4

2 months ago
Reopened because this can still be 100% reproduced. Just because nobody is as mad and sends 2 GiB in a single `send` call, it doesn't make it less of a bug.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Keywords: crash, testcase
You need to log in before you can comment on or make changes to this bug.