If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Fetch not sending network request

RESOLVED WONTFIX

Status

()

Toolkit
WebExtensions: General
RESOLVED WONTFIX
2 months ago
2 months ago

People

(Reporter: ober.sebastian, Unassigned)

Tracking

54 Branch
Points:
---

Firefox Tracking Flags

(firefox54 wontfix, firefox55 unaffected)

Details

(Reporter)

Description

2 months ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170717063821

Steps to reproduce:

Using a web extension with permission to *://api.pinboard.in/*, trying to send a fetch get request to that domain. It does not work in firefox release (v54), while working in firefox v55.0b10 dev edition and chrome.


Actual results:

No request is sent (according to network tab) and promise never resolved. The line of code before is executed, no error message shown


Expected results:

Network request gets sent and resolved.

Updated

2 months ago
Component: Untriaged → WebExtensions: General
Product: Firefox → Toolkit
55 is due to be released Aug 8, since report says it works there, wontfix for 54
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 months ago
status-firefox54: --- → wontfix
status-firefox55: --- → unaffected
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.