Flash Player - Tab and Shift Tab functions are reversed on Linux in Firefox 49 and higher

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
RESOLVED WORKSFORME
4 months ago
4 months ago

People

(Reporter: Jeromie Clark, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.82 KB, application/x-shockwave-flash
Details
(Reporter)

Description

4 months ago
Created attachment 8888535 [details]
CursorNavigation.swf

Method:
1.) Run the attached SWF in Firefox
2.) Set the focus to TextField1, press "Tab" key
3.) Set the focus to TextField1, press "Shift+Tab" key

Result:
For step4, press "Tab" key the focus change to TextField3.
For step5, press "Shift+Tab" key the focus change to TextField2.

Expected:
For step4, press "Tab" key, the focus should be change to TextField2.
For step5, press "Shift+Tab" key, the focus should be change to TextField3.
(Reporter)

Updated

4 months ago
Summary: Tab and Shift Tab functions are reversed on Linux in Firefox 49 and higher → Flash Player - Tab and Shift Tab functions are reversed on Linux in Firefox 49 and higher

Comment 1

4 months ago
Is this just wontfix, Benjamin? Is anyone working on flash/plugin stuff at this point?
Component: General → Flash (Adobe)
Flags: needinfo?(benjamin)
Product: Firefox → External Software Affecting Firefox
Version: 49 Branch → unspecified

Updated

4 months ago
Component: Flash (Adobe) → Plug-ins
Flags: needinfo?(benjamin) → needinfo?(jmathies)
Product: External Software Affecting Firefox → Core

Comment 2

4 months ago
Karl, any comments here? I'm not familiar with Linux keyboard shortcuts.
Flags: needinfo?(jmathies) → needinfo?(karlt)
I get expected behavior with s/step5/step4/ and a build based on m-c 7d2e89fb9233.  Similarly with 55.0b3 and 49.0.2.
I guess it is possible that this only reproduces with some keymaps.
What does "setxkbmap -query" print?

Or an IME may be involved.

Probably the best way to get a clue to the cause of the change is to find a regression window.
https://blog.nightly.mozilla.org/2016/10/11/found-a-regression-in-firefox-give-us-details-with-mozregression/

Bug 1337781 was my only guess at what may have caused a behavior change, but that went into 54.
Flags: needinfo?(karlt) → needinfo?(jeclark)
(Reporter)

Comment 4

4 months ago
Sorry for the delay.  I was waiting on our internal reporter.

It appears that this issue has been resolved as of Firefox 54.0.1.  Please feel free to close it.
Flags: needinfo?(jeclark)

Comment 5

4 months ago
Closing per comment #4. Thank you!
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.