Firefox macOS: window in full screen - creating a new window does not enter full screen

RESOLVED DUPLICATE of bug 1405577

Status

()

P3
normal
RESOLVED DUPLICATE of bug 1405577
a year ago
10 months ago

People

(Reporter: bassnh, Unassigned)

Tracking

54 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(firefox55 wontfix, firefox56 fix-optional, firefox57- fix-optional)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170628075643

Steps to reproduce:

1. Open Firefox on macOS
2. Create a new window (Cmd+N)
2. Take that window to full screen (Ctrl+Cmd+F)
3. While in full screen create a second new window (Cmd+N)


Actual results:

The second new window does not enter full screen and instead sits on top of the first window already in full screen.


Expected results:

The second new window should open in a new full screen window.
Component: Untriaged → Shell Integration
This happens in nightly too

Updated

a year ago
OS: Unspecified → Mac OS X
Hardware: Unspecified → x86
Component: Shell Integration → Widget: Cocoa
Product: Firefox → Core
Duplicate of this bug: 1386795

Comment 3

a year ago
[Tracking Requested - why for this release]:
status-firefox57: --- → ?
tracking-firefox57: --- → ?
Seems like a corner case, also not new in 57, not tracking.
status-firefox55: --- → wontfix
status-firefox56: --- → fix-optional
status-firefox57: ? → fix-optional
tracking-firefox57: ? → -
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3

Comment 5

a year ago
I noticed this issue today, since I am using Firefox Trunk atm to find Photon Bugs. Please fix this bug for the 57 release, since this is a macOS main feature. Thank you!

Comment 6

a year ago
I noticed this same issue today with Quantum Beta. I'm attaching a screenshot for reference

Comment 7

a year ago
Created attachment 8914045 [details]
New window on top of fullscreen window on macOS High Sierra

Updated

11 months ago
Duplicate of this bug: 1406692

Comment 9

11 months ago
Similar issue with Quantum beta, Firefox should also start in fullscreen on startup if I last used it in fullscreen.

Comment 10

10 months ago
Moreover, (Cmd + ~) doesn't bring the window originally in full screen to the front. It simply switches the windows while the new window which was created stays on top of the full screen one.
This bug as originally reported is a duplicate of bug 1405577, which has been fixed recently.

(In reply to chancharge from comment #9)
> Similar issue with Quantum beta, Firefox should also start in fullscreen on
> startup if I last used it in fullscreen.

This is a duplicate of bug 1423520.

(In reply to Pranjal Goel from comment #10)
> Moreover, (Cmd + ~) doesn't bring the window originally in full screen to
> the front. It simply switches the windows while the new window which was
> created stays on top of the full screen one.

Please retest with a build after bug 1405577 landed. If this still reproduces, please file a new bug.
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1405577

Comment 12

10 months ago
Thanks for fixing this bug.

I noticed two follow up bugs:

Bug 1424056 and Bug 1424059
You need to log in before you can comment on or make changes to this bug.