Closed Bug 1382891 Opened 7 years ago Closed 7 years ago

Automatically focus search field as soon as the page is opened

Categories

(Firefox :: New Tab Page, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 57
Tracking Status
firefox57 + fixed

People

(Reporter: marco, Assigned: rrosario)

References

Details

It's useful if about:newtab is set as the homepage.
Although for those using it as a new tab, those users would be expecting focus to be in the location bar. There are plans to have activity stream replace about:home, so that potentially could have logic to focus for about:home but not for about:newtab.
(In reply to Ed Lee :Mardak from comment #1)
> Although for those using it as a new tab, those users would be expecting
> focus to be in the location bar. There are plans to have activity stream
> replace about:home, so that potentially could have logic to focus for
> about:home but not for about:newtab.

It's fine for me if the location bar is focused. The problem is that at the moment whatever you type when you launch Firefox (with about:newtab as home page) is lost.
Design says wontfix and that activity stream as home page will actually focus location bar. See bug 1393246
See Also: → 1393246
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WONTFIX
Nevermind. Product wants to avoid search metrics changes.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Blocks: 1394533
[Tracking Requested - why for this release]: Since Activity Stream is now the home page, we should focus something (either location bar or search field) automatically when it opens.
Fixed by https://github.com/mozilla/activity-stream/pull/3452 uplifted by bug 1399607.
Assignee: nobody → rrosario
Blocks: 1399607
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Seems like there's a lot of back and forth on where the focus should be...
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.