Closed Bug 1383038 Opened 4 years ago Closed 4 years ago

Setting a browser permission fails with undefined win.PopupNotifications

Categories

(WebExtensions :: General, defect)

56 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1382953

People

(Reporter: gregtatum, Unassigned)

Details

STR:
 * Use Nightly
 * Go to https://perf-html.io
 * Install the add-on
 * Go to about:addons
 * Change the Profile viewer URL
 * Hit save
 * The save will randomly work, and randomly fail. Most often it fails.
 * The error in Browser Console is "win.PopupNotifications is undefined" in ExtensionsUI.jsm


Error location:

http://searchfox.org/mozilla-central/rev/3a3af33f513071ea829debdfbc628caebcdf6996/browser/modules/ExtensionsUI.jsm#441

Here is our code:

https://github.com/devtools-html/Gecko-Profiler-Addon/blob/0d835596c5a93e1ebc02d328a1cccb369f67e5f0/options.js#L19-L29
We tracking our side of the issue here: https://github.com/devtools-html/Gecko-Profiler-Addon/issues/89
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1382953
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.