Intermittent TEST-UNEXPECTED-PASS | /cssom-view/elementFromPoint.html | Fieldsets - expected FAIL

RESOLVED FIXED in Firefox 56

Status

defect
RESOLVED FIXED
2 years ago
7 months ago

People

(Reporter: intermittent-bug-filer, Assigned: jgraham)

Tracking

({intermittent-failure})

Version 3
mozilla56
Points:
---

Firefox Tracking Flags

(firefox56 fixed)

Details

(Whiteboard: [stockwell disabled])

Attachments

(1 attachment)

These were apparently only running against m-c until a patch currently on autoland turned them on elsewhere. So expect more failures to flood in now.
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
james: can you take a look, this is happing frequently
Flags: needinfo?(james)
Comment hidden (mozreview-request)

Comment 6

2 years ago
mozreview-review
Comment on attachment 8889309 [details]
Bug 1383056 - Disable unstable elementFromPoint test on win 10,

https://reviewboard.mozilla.org/r/160376/#review165616

thanks james!
Attachment #8889309 - Flags: review?(cbook) → review+

Comment 7

2 years ago
Pushed by cbook@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/00eedf2ff919
Disable unstable elementFromPoint test on win 10, r=Tomcat
Assignee

Updated

2 years ago
Flags: needinfo?(james)
Whiteboard: [stockwell disabled]

Comment 8

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/00eedf2ff919
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Assignee: nobody → james
Comment hidden (Intermittent Failures Robot)
So there is definitely an issue here, and I suspect it's the test, not Firefox.  If you look  at https://wpt.fyi/results/css/cssom-view/elementFromPoint.html?aligned&label=stable every single browser fails the "Fieldsets" test over there.  But when I test locally by just loading http://w3c-test.org/css/cssom-view/elementFromPoint.html I get a pass in Firefox, Chrome, and Safari (didn't test Edge).
Flags: needinfo?(james)
Assignee

Comment 13

7 months ago
I think looking at stable releases here is misleading, for prerelease browsers there are a lot of passes: https://wpt.fyi/results/css/cssom-view/elementFromPoint.html?label=experimental

On linux using nightly I can't make the test fail, and it looks like the issue is almost entirely on Windows 10. My guess is that it's either that the test is making inaccurate assumptions about what the control looks like on Windows, or that it's somehow focus related.
Assignee

Comment 14

7 months ago
I can't make the test fail on Windows 10 either. Given that this was disabled a year ago and the test has different behaviour in nightly and stable, I'm guessing it's OK to reenable the test on Windows now.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=1f191696db618f776e1d95a062c19b4348170227
Flags: needinfo?(james)
> Given that this was disabled a year ago and the test has different behaviour in nightly and stable

Hmm.  I was getting passes in stable too, but I do see that in wpt automation at least it passes in nightlies.

Filed bug 1502948 to re-enable.
You need to log in before you can comment on or make changes to this bug.