When pressing F6 while the mouse cursor is over a tab so that the tab's title is shown as tooltip, Firefox stops responding.

RESOLVED WORKSFORME

Status

()

Firefox
Tabbed Browser
--
critical
RESOLVED WORKSFORME
5 months ago
3 months ago

People

(Reporter: ertl.maxi, Unassigned)

Tracking

({hang})

54 Branch
Unspecified
Windows 10
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox54 affected, firefox55 unaffected, firefox56 unaffected, firefox57 unaffected)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 months ago
Created attachment 8888789 [details]
Screenshot of a tab and its tooltip.

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3159.5 Safari/537.36

Steps to reproduce:

1. Hover above any open tab until its title is shown in a tooltip (see attached screenshot).
2. Press F6 to move the cursor to the Address bar

Tested and reproduced on:
a.) FF 54.0.1 (64-Bit) on Win10 Pro Insider Preview, build 16241.1001
b.) FF 54.0.1 (64-Bit) on Win10 Enterprise, build 14393.0 (3 identical machines)

Tested and NOT reproduced on:
c.) FF 54.00.1 (x64) on Arch Linux x86_64 Kernel 4.11.3-1


Actual results:

Firefox hangs, any further interaction will bring up Windows' "Firefox isn't responding. Wait/Close" dialog.


Expected results:

The cursor should be moved to the Address bar and the text in it (ie the URL of the current webpage) should be selected.

Updated

5 months ago
Component: Untriaged → Tabbed Browser
OS: Unspecified → Windows 10

Updated

5 months ago
Severity: normal → critical
Status: UNCONFIRMED → NEW
Has Regression Range: --- → no
Has STR: --- → yes
status-firefox54: --- → affected
status-firefox55: --- → unaffected
status-firefox56: --- → unaffected
status-firefox-esr52: --- → unaffected
Component: Tabbed Browser → Untriaged
Ever confirmed: true
Keywords: hang

Comment 1

5 months ago
I've used mozregression to find a regression range. Here are my findings: 

Last good revision: 66e7178c31542d5cc6f893c3998ad17bf6845075
First bad revision: 586d65b40b24824331a16be1fe94f74e2e113a15
Pushlog: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=66e7178c31542d5cc6f893c3998ad17bf6845075&tochange=586d65b40b24824331a16be1fe94f74e2e113a15

Updated

5 months ago
Duplicate of this bug: 1364119

Updated

4 months ago
status-firefox57: --- → unaffected

Updated

3 months ago
Component: Untriaged → Tabbed Browser
Are you still seeing this?

Flags since set on this bug seem to imply this _only_ affected Firefox 54 (not ESR, and not 55+). If that's actually the case, we can close the bug.


(In reply to Stefan [:StefanG_QA] from comment #1)
> I've used mozregression to find a regression range. Here are my findings: 
> 
> Last good revision: 66e7178c31542d5cc6f893c3998ad17bf6845075
> First bad revision: 586d65b40b24824331a16be1fe94f74e2e113a15
> Pushlog:
> https://hg.mozilla.org/integration/mozilla-inbound/
> pushloghtml?fromchange=66e7178c31542d5cc6f893c3998ad17bf6845075&tochange=586d
> 65b40b24824331a16be1fe94f74e2e113a15

I'm not sure I believe that range. Bug 1325090 seems exceedingly unlikely to have caused this behavior, it's just removing some telemetry probes.
Flags: needinfo?(ertl.maxi)
(Reporter)

Comment 4

3 months ago
I don't see the issue anymore, at least on my main PC where I was previously able to reproduce the issue (and I can't test it on another machine right now). I'd say it's safe to close the bug if nobody else is still experiencing it on Firefox 55.
Flags: needinfo?(ertl.maxi)

Updated

3 months ago
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.