Menulist widths are not calculated correctly to fit longest menupopup string

VERIFIED DUPLICATE of bug 135089

Status

()

Core
XUL
VERIFIED DUPLICATE of bug 135089
16 years ago
10 years ago

People

(Reporter: Charles Manske, Assigned: Brian Ryner (not reading))

Tracking

({regression})

Trunk
x86
Windows 2000
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
The default behavior for calculating the preferred width of a menulist should be 
to fit the longest string in the child menupopup->menuitems without cropping.
The most noticeable case is inn Composer: the Paragraph Style menulist on the 
formating toolbar should show "Body Text", but not it shows "Body T...".
There are many examples in Composer dialogs are being cropped, e.g.,
1. Click on the Table button and insert a default table. 
2. Dbl click in a cell to bring up Table Properties dialog
3. In the "Size" group, change the "Height" menulist from "pixels" to "% of
table" the later string will be cropped.
Change "Vertical" alignment menulist from "Top" to "Bottom" and latter will be 
cropped. 
In the Image dialog (click on Image toolbar button):
1. Change to the "Appearance" tab. The alignment menulist shows "At the..."
when it should be "At the Bottom"

I tested the 1.0 branch build and it does NOT show the cropped "Body Text" in 
pargraph menulist on Composer toolbar, but it does show the other examples 
of cropping text in various dialog menulists.
(Reporter)

Updated

16 years ago
Keywords: nsbeta1, regression, ui

Comment 1

16 years ago
Charley, I don't see this in my theme, it may be a themes issue.
(Reporter)

Comment 2

16 years ago
Neil: I'm not surprised. I've been investigating and experiment with changing 
padding on the menulist "text box" as well as for menutitems and can definitely 
affect whether or not the cropping occures. I think a basic flaw is now allowing
space for the arrow icon that triggers the menupopup. I'd be interested in seeing
the CSS for you theme: for menulist.css and menu.css.
(Reporter)

Comment 3

16 years ago
Looks like others have found the same problem.

*** This bug has been marked as a duplicate of 135089 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
mass duplicate verifications . For filtering purposes, pls use keywd
"massdupverification"

Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: shrir → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.