Unplugging your VR device displays no error prompt

RESOLVED DUPLICATE of bug 1397397

Status

()

RESOLVED DUPLICATE of bug 1397397
a year ago
a year ago

People

(Reporter: ccomorasu, Unassigned)

Tracking

Trunk
All
Windows 10
Points:
---

Firefox Tracking Flags

(firefox55 affected)

Details

[Affected versions]:
 Fx 55.0.10

[Affected platforms]:
 Windows 10 x64

[Steps to reproduce]:
 1. Launch Fx and go to https://aframe.io/a-blast/ .
 2. Click from the page the VR button to start the demo.
 3. Play the game.
 4. Unplug your device.
 5. Plug the device back in.
 
[Expected result]:
 The browser warns the user about the disrupt.

[Actual result]:
 The VR device is off even after the re-connection and the browser displays the game.

[Regression range]:
 

[Additional notes]:
-
A VRDisplayDisconnect event is emitted when the headset is disconnected; however, most content is not listening to this message due to other browsers not yet fully implementing it.

We should verify that the event is emitted and that the browser does not crash; otherwise, I don't think this should block release.
A-Frame listens to the vrdisplayactivate \ vrdisplaydeactivate events. They fired as expected on reloads of the same page or page navigation but the events don't seem to be triggered by the Oculus proximity sensor when putting the headset on / off or when disconnecting the cable on neither Vive or Rift.
Not sure if the browser should notify the user about a headset being plugged or unplugged (an eventual icon indicating a present headset could cover for this) but content should have the possibility to react to those events.
Additional info: vrdisplayconnected / vrdisplaydisconnected only fires for Oculus Rift when unplugging the USB cable. It does not work for HTC VIve.
The events firing for HTC Vive has been fixed in Bug 1397397.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1397397
You need to log in before you can comment on or make changes to this bug.