Closed Bug 1383387 Opened 4 years ago Closed 4 years ago

Crash in webrtc::videocapturemodule::VideoCaptureImpl::Create

Categories

(Core :: WebRTC, defect)

56 Branch
Unspecified
macOS
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1379392
Tracking Status
firefox-esr52 --- unaffected
firefox54 --- unaffected
firefox55 --- unaffected
firefox56 --- fixed

People

(Reporter: philipp, Unassigned)

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-c01faaf9-e1f5-49d2-b983-2be210170719.
=============================================================
Crashing Thread (74)
Frame 	Module 	Signature 	Source
0 	XUL 	webrtc::videocapturemodule::VideoCaptureImpl::Create(char const*) 	media/webrtc/trunk/webrtc/base/scoped_ref_ptr.h:100
1 	XUL 	webrtc::VideoCaptureFactory::Create(char const*) 	media/webrtc/trunk/webrtc/modules/video_capture/video_capture_factory.cc:19
2 	XUL 	mozilla::camera::VideoEngine::CreateVideoCapture(int&, char const*) 	dom/media/systemservices/VideoEngine.cpp:52
3 	XUL 	mozilla::media::LambdaRunnable<mozilla::camera::CamerasParent::RecvAllocateCaptureDevice(mozilla::camera::CaptureEngine const&, nsCString const&, mozilla::ipc::PrincipalInfo const&)::$_8::operator()() const::'lambda'()>::Run() 	dom/media/systemservices/CamerasParent.cpp:715
4 	XUL 	nsThread::ProcessNextEvent(bool, bool*) 	xpcom/threads/nsThread.cpp:1446
5 	XUL 	NS_ProcessNextEvent(nsIThread*, bool) 	xpcom/threads/nsThreadUtils.cpp:489
6 	XUL 	mozilla::ipc::MessagePumpForNonMainThreads::Run(base::MessagePump::Delegate*) 	ipc/glue/MessagePump.cpp:369
7 	XUL 	MessageLoop::Run() 	ipc/chromium/src/base/message_loop.cc:320
8 	XUL 	base::Thread::ThreadMain() 	ipc/chromium/src/base/thread.cc:181
9 	XUL 	ThreadFunc(void*) 	ipc/chromium/src/base/platform_thread_posix.cc:38
10 	libsystem_pthread.dylib 	_pthread_body 	
11 	libsystem_pthread.dylib 	_pthread_start 	
12 	libsystem_pthread.dylib 	thread_start 	
13 	XUL 	XUL@0x54191f

this is a low volume crash signature on macos newly showing up on 56.0a1 (first time in build 20170628192309), maybe related to bug 1341285?
Flags: needinfo?(rjesup)
Should be fixed in today's Nightly.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(rjesup)
Resolution: --- → DUPLICATE
Duplicate of bug: 1379392
Mark 56 fixed as bug 1379392 was fixed in 56.
You need to log in before you can comment on or make changes to this bug.