NEED Proxy Command Option

RESOLVED WONTFIX

Status

()

Core
Networking
--
enhancement
RESOLVED WONTFIX
16 years ago
2 years ago

People

(Reporter: James Barwick, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I really need (as do many) a command line option to enable -p1 or disable -p0
proxies on startup. (assume that proxy IP's have already been entered).

I'd like to be able to "c:\mozilla\mozilla -p1" 
                    or "c:\mozilla\mozilla -p0"

I change two to three times a day (back and forth, dialup vs LAN)

Also, need to have a hot key....CTL-ALT-F9 (something like that)
pops up a box if proxy enbabled "Disable Proxies?" YES/NO or pops up a box if
proxy disabled "Enable Proxies?" YES/NO

Yes, I know it's easy to go Edit/Preferences/Advanced/Proxies/Radio
Button/OK...but it's just a lot of steps....pain.

This would really be a cool feature.

Comment 1

16 years ago
Marking this bug as a DUPLICATE of bug 100523

If you disagree with this action, please feel free to REOPEN this bug. Thanks
for helping with mozilla.

*** This bug has been marked as a duplicate of 100523 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

16 years ago
100523 appears to me to be a COMPLETELY different issue.  Although the bog
100523 starts off saying, "I need a way to update proxy settings without
drilling down", it ENDS in a COMPLETELY different direction dealing with
problems moving networks and "not picking up DHCP changes" as the root problem.

Although not picking up DHCP changes is a problem (as I've noticed before)...my
ENHANCEMENT request as NOTHING to do iwt that.  I'm perfectly willing to stop
and restart the browser when I change networks.  My enhancement requrest says
"put command line parameters" on mozilla so I don't have to drill down and
change proxy settings every time I change networks.

Leave 100523 as a "BUG" that says "mozilla doesn't automatically pick up DHCP
changes".

These appear to me to be VERY different issues.  One is configuration of the
browser, the other is a bug.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

16 years ago
To be honest, I disagree. bug 10523 is quite clearly titled: [RFE]quick proxy
switching for mobile/roaming users which seems to be the aim of your request.
That is not the bug for the DHCP issues, it is one for development of proxy
configuration designed for people who want to change it easily on the fly. I
assumed that this would be better than what you suggested. I really doubt that
we want loads of command line parameters for every setting people might want to
be different on each startup - we are not a command line app.

Anyway, just my humble opinion - sorry for any inconvenience caused.

David

Comment 4

16 years ago
duping again. I agree with David. although there's some discussion of different
issues in the comments, that bug is what the summary and the original report say
it is - a way of quickly switching between proxies.  that's what you want, isn't it?


*** This bug has been marked as a duplicate of 100523 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE

Comment 5

14 years ago
This is XP-line commands, as I understand it.
Status: RESOLVED → UNCONFIRMED
Component: XPCOM → XP Apps: Cmd-line Features
Resolution: DUPLICATE → ---

Comment 6

14 years ago
-> defaults.

This bug is a depends on bug 43429.

First we would have to implement that, then we would need to add the line
command support.

Please think along component lines. If your feature will use (or add) other
stuff, you need to talk to module owners and default owners of the components to
see if you will need to create depends bugs. 
Status: UNCONFIRMED → NEW
Depends on: 43429
Ever confirmed: true

Updated

13 years ago
URL: N/A
Component: Cmd-line Features → Networking

Comment 7

10 years ago
mass reassigning to nobody.
Assignee: dougt → nobody

Comment 8

10 years ago
Why don't we just close this.  As folks don't agree that we should have a command line option availalable, and we'll all deal with "ProxySwitch" or some other add-on to change proxies after Firefox starts...making the user do it himself....ok

I had a specific business process I was trying to implement...but this was a long time ago...and we went a different direction (Using I.E and writing a batch and executable program to change Registry settings for proxy connections)...So, this is no-longer required of mozilla/firefox.

So...I guess this isn't necessary...

QA Contact: scc → networking
Status: NEW → RESOLVED
Last Resolved: 16 years ago2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.