If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

stylo: Issues with :hover on wykop.pl

VERIFIED FIXED

Status

()

Core
CSS Parsing and Computation
P2
normal
VERIFIED FIXED
2 months ago
2 months ago

People

(Reporter: kasper93, Unassigned)

Tracking

(Blocks: 1 bug, {nightly-community})

Trunk
nightly-community
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

2 months ago
Hello,

The problem:
* Highlight doesn't happen at once for all elements. Some blink twice before being highlighted or elements highlight in steps. You will see what I mean once you try it.
* If you move mouse pointer quickly over items. fa icons will remain highlighted while they shouldn't. 

STR:

1. Go to https://www.wykop.pl/ You will see list of items with thumbnails.
2. Each item has /[0-9]+ komentarzy/ on the bottom, hover on it.
3. You will see some elements highlights. Notably domain name, tag list and mentioned "komentarzy" string with icon.


Please tell me if you were able to reproduce. It is hard to explain so I will try more if needed.

- Kacper
(Reporter)

Updated

2 months ago
Blocks: 1375906
The first issue may be somehow related to bug 1380368, and the second issue sounds very much like a dupe of bug 1381821.
(Reporter)

Comment 2

2 months ago
Thanks, indeed it looks like a dupe of bug 1381821. But I would like to keep it open until there is a fix to keep track of this specific site. To be sure we don't miss any issue here.
(In reply to Kacper Michajłow [:kasper93] from comment #0)
> Hello,
> 
> The problem:
> * Highlight doesn't happen at once for all elements. Some blink twice before
> being highlighted or elements highlight in steps. You will see what I mean
> once you try it.
> * If you move mouse pointer quickly over items. fa icons will remain
> highlighted while they shouldn't. 

I can't reproduce either, but the first one seems to be bug 1380133, the latter seems to be bug 1381235.
Depends on: 1380133, 1381821, 1381235
Priority: -- → P2
(In reply to Hiroyuki Ikezoe (:hiro) from comment #3)
> (In reply to Kacper Michajłow [:kasper93] from comment #0)
> > Hello,
> > 
> > The problem:
> > * Highlight doesn't happen at once for all elements. Some blink twice before
> > being highlighted or elements highlight in steps. You will see what I mean
> > once you try it.
> > * If you move mouse pointer quickly over items. fa icons will remain
> > highlighted while they shouldn't. 
> 
> I can't reproduce either, but the first one seems to be bug 1380133, the
> latter seems to be bug 1381235.

Me either(BID: 20170725144001). Could you help to verify again on latest Nightly build?
Flags: needinfo?(kasper93)
Created attachment 8890589 [details]
2017-07-27_01-12-40.mp4

I can reproduce this in Nightly 56 x64 20170726100241 @ Debian Testing
and it's exactly the same I have in bug 1382742 (compare with the 2 screencasts there).
Severity: major → normal
Status: UNCONFIRMED → NEW
Has STR: --- → yes
Ever confirmed: true
Keywords: nightly-community
See Also: → bug 1382742
Version: 56 Branch → Trunk
Thanks Darksripit! The video helped me to understand this issue.  To reproduce this we need to click the link once. so it's visited style!
Could you please try a try build in bug 1381235 comment 14. It should work fine!
(In reply to Hiroyuki Ikezoe (:hiro) from comment #6)
> Thanks Darkspirit! The video helped me to understand this issue. To reproduce this we need to click the link once. so it's visited style! Could you please try a try build in bug 1381235 comment 14. It should work fine!

Yes, it seems to be fixed like bug 1382742 comment 13.
Closing since the fix for bug 1381235 has been merged into mozilla-central.

https://hg.mozilla.org/mozilla-central/rev/5894beca0ec2
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → FIXED
(Reporter)

Comment 9

2 months ago
Yes, this issue if fixed. Thanks.
Flags: needinfo?(kasper93)
(In reply to Darkspirit from comment #5)
> Created attachment 8890589 [details]
> 2017-07-27_01-12-40.mp4
> 
> I can reproduce this in Nightly 56 x64 20170726100241 @ Debian Testing
> and it's exactly the same I have in bug 1382742 (compare with the 2
> screencasts there).

Verified fixed in Nightly 56 x64 20170729100254 @ Debian Testing
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.