Flexible space item shows "Pin to Overflow Menu" item in context menu

VERIFIED FIXED in Firefox 56

Status

()

P1
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: bruce.bugz, Assigned: Gijs)

Tracking

(Blocks: 1 bug)

56 Branch
Firefox 56
Points:
---

Firefox Tracking Flags

(firefox56 fixed, firefox57 verified)

Details

(Whiteboard: [photon-structure])

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20170722072631

Steps to reproduce:

1. Get the overflow menu icon to show up by pinning an item, say the home button, into it.
2. Go into the Customize mode, and add a flexible space onto the nav-bar. Exit Customize mode.
3. Right click this flexible space.


Actual results:

1. There is a "Pin to Overflow Menu" item on the menu, and it is not disabled.
2. Clicking it doesn't remove the flexible space, but the something-was-pinned-to-overflow-menu animation plays out.


Expected results:

The "Pin to Overflow Menu" item should probably be disabled, as per https://bugzilla.mozilla.org/show_bug.cgi?id=1366813#c0 ("you can only add flexible spacers to toolbars, not panels")
(Reporter)

Updated

2 years ago
Has STR: --- → yes
Component: Untriaged → Toolbars and Customization
(Assignee)

Updated

2 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: qe-verify+
QA Contact: gwimberly
Whiteboard: [photon-structure][triage]
Priority: -- → P2
Whiteboard: [photon-structure][triage] → [photon-structure]
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Iteration: --- → 56.4 - Aug 1
Priority: P2 → P1
Comment on attachment 8890428 [details]
Bug 1383458 - disable pin to overflow / move to panel for flexible spacers (and other special items),

https://reviewboard.mozilla.org/r/161532/#review166838

::: browser/components/customizableui/test/browser_photon_customization_context_menus.js:436
(Diff revision 1)
>  });
> +
> +// Bug 1383458 - shouldn't enable 'pin to overflow menu' for flexible spaces
> +add_task(async function flexible_space_context_menu() {
> +  CustomizableUI.addWidgetToArea("spring", "nav-bar");
> +  let springs = document.getElementById("nav-bar").querySelectorAll("toolbarspring");

document.querySelectorAll("#nav-bar toolbarspring")
Attachment #8890428 - Flags: review?(jaws) → review+
Comment hidden (mozreview-request)

Comment 4

2 years ago
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/b6da3839bc2a
disable pin to overflow / move to panel for flexible spacers (and other special items), r=jaws

Comment 5

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/b6da3839bc2a
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox56: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 56
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1385018

Comment 7

2 years ago
I have reproduced this bug with Nightly 56.0a1 (2017-07-22) on Windows 8.1 (64 Bit)

This bug's fix is verified on Latest Nightly 56.0a1.

Build ID : 20170801100311
User Agent : Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
QA Whiteboard: [bugday-20170802]

Comment 8

2 years ago
Verified on Windows, Mac, and Ubuntu.
Status: RESOLVED → VERIFIED
status-firefox57: --- → verified
Flags: qe-verify+

Updated

2 years ago
Blocks: 1387512
You need to log in before you can comment on or make changes to this bug.