Status

()

defect
P1
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: sandken, Assigned: jhlin)

Tracking

({regression})

56 Branch
Firefox 56
Points:
---

Firefox Tracking Flags

(firefox54 unaffected, firefox55blocking verified, firefox56+ verified)

Details

(Whiteboard: [testcoverage])

Attachments

(3 attachments)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20170722120123

Steps to reproduce:

Click on any Youtubd video'


Actual results:

"Buffering" icon shows, video doesn't play. See screenshot.


Expected results:

Video should have played.

Videos play okay on stable 54 and beta 55. I don't know exactly when this happened, but 14 days ago, I could play videos when I encountered a different bug 1379389
Forgot to say I'm using a Verizon Ellipsis 10 tablet, Android 5.1, Verizon software update IR7_20C63.
Thanks for firing this bug. 
Can you still see this bug if you reboot your device?
Further investigation shows Firefox Nightly won't play any video.
Summary: Can't play any Youtube video → Can't play any video
(In reply to Blake Wu [:bwu][:blakewu] from comment #2)
> Thanks for firing this bug. 
> Can you still see this bug if you reboot your device?

Reboot doesn't fix; problem still exists. Also I've found this is not restricted to Youtube; can't play any video.
Thanks for this info. 
John,
Could you check this?
Flags: needinfo?(jolin)
Priority: -- → P1
(In reply to Anthony Jones (:kentuckyfriedtakahe, :k17e) from comment #6)
> Reproducible on Huawei P10. Regression range
> https://hg.mozilla.org/mozilla-central/
> pushloghtml?fromchange=1b065ffd8a535a0ad4c39a912af18e948e6a42c1&tochange=0985
> 725c848ec0cfc6f2f3c3a5aa3d71321e7620

 Do you by any chance have the logcat dump to help investigation?
Flags: needinfo?(jolin)
Flags: needinfo?(ajones)
This bug has now appeared in beta 55 2015502025.
[Tracking Requested - why for this release]:

This issue breaks all playback on some handsets including Huawei's flagship P10 phone.
Flags: needinfo?(ajones)
What phone are you having this issue on?
Flags: needinfo?(sandken)
Whiteboard: [testcoverage]
Thanks to the excellent support from ssergiu@softvision, I've identify the root cause.
This is a regression caused by the patch in bug 1365205, which rejects null output buffers.
Unfortunately, some decoders return null output buffers when it's configured with output surface and all output buffers they produce were considered invalid [1].

[1] http://searchfox.org/mozilla-central/source/mobile/android/geckoview/src/main/java/org/mozilla/gecko/media/Codec.java#267
Assignee: nobody → jolin
Sounds like this might be a blocker for 55 if it affects popular phones.
(In reply to Anthony Jones (:kentuckyfriedtakahe, :k17e) from comment #10)
> What phone are you having this issue on?

Verizon Ellipsis 10 tablet -desktop mode - Android 5.1 - Verizon software update level IR7_20C63.
Flags: needinfo?(sandken)
Comment on attachment 8890717 [details]
Bug 1383479 - allow null output buffers when codec is configured with output surface.

https://reviewboard.mozilla.org/r/161918/#review167770

I feel responsible for this one, good find!
Attachment #8890717 - Flags: review?(esawin) → review+
Pushed by jolin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/59507e1a1b96
allow null output buffers when codec is configured with output surface. r=esawin
https://hg.mozilla.org/mozilla-central/rev/59507e1a1b96
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 56
Hi John,
Could you please help request beta uplift approval right away today's morningin?
Flags: needinfo?(jolin)
(In reply to Hsin-Yi Tsai (55 Regression Engineering support) [:hsinyi] from comment #18)
> Hi John,
> Could you please help request beta uplift approval right away today's
> morningin?

typo: s/morningin/morning

We will have to make it uplifted today's afternoon.
Comment on attachment 8890717 [details]
Bug 1383479 - allow null output buffers when codec is configured with output surface.

Approval Request Comment
[Feature/Bug causing the regression]: 1365205
[User impact if declined]: cannot play video on certain devices
[Is this code covered by automated tests?]:no
[Has the fix been verified in Nightly?]:yes
[Needs manual test from QE? If yes, steps to reproduce]: Yes. Play any video on Huawei P10 and see if works.
[List of other uplifts needed for the feature/fix]:none
[Is the change risky?]:low risk
[Why is the change risky/not risky?]:for video decoding, only the buffer info is needed rather than its contents.
[String changes made/needed]:none
Flags: needinfo?(jolin)
Attachment #8890717 - Flags: approval-mozilla-beta?
Comment on attachment 8890717 [details]
Bug 1383479 - allow null output buffers when codec is configured with output surface.

video regression fix for fennec 55.0b14
Attachment #8890717 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Devices:
 - Huawei P10 (Android 7.0);
 - Huawei MediaPad M2 (Adnroid 5.1.1).

Builds:
 - Beta - 55.0b14;
 - Nightly - 56.0a1 (2017-07-31);

Hello,
Verified this issue and it is no longer reproducible in beta.
Nightly still seems to be affected on the P10.
(In reply to Bogdan Surd, QA [:BogdanS] from comment #23)
> Nightly still seems to be affected on the P10.

  Thanks a lot for the verification. Could you please type 'about:buildconfig' in the address bar of Nightly and upload the screenshot?
Flags: needinfo?(bogdan.surd)
Posted image one.png
Sure, here is the screenshot you requested.
Flags: needinfo?(bogdan.surd)
Bogdan, thanks a lot for the prompt support. It looks like the Nightly you tested was built from 2017-07-26 changeset which doesn't include the needed patch.

Could you please download and install the APK from [1], and see if it is still affected?

[1] https://archive.mozilla.org/pub/mobile/nightly/latest-mozilla-central-android-api-15/fennec-56.0a1.multi.android-arm.apk
Flags: needinfo?(bogdan.surd)
Hello,

Thanks John, with the apk provided video playback works without any issue for both mobile and desktop versions of the site. Marking as verified.
Status: RESOLVED → VERIFIED
Flags: needinfo?(bogdan.surd)
You need to log in before you can comment on or make changes to this bug.