Closed Bug 1383519 Opened 2 years ago Closed 2 years ago

"Bookmark all tabs" broken with browser.places.useAsyncTransactions true

Categories

(Firefox :: Bookmarks & History, defect)

56 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1383138

People

(Reporter: ajfhajf, Unassigned)

Details

Attachments

(1 file)

Attached image OK menu vs broken menu
User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20170722072631

Steps to reproduce:

Create new profile, launch it, there will be two tabs open
Right click on any of them - "Bookmark All tabs"
By default browser.places.useAsyncTransactions true, bug is not reproduced with browser.places.useAsyncTransactions false


Actual results:

Name and Folder fields are missing. Empty folder called [Folder name] is created after I press "Add bookmarks", bookmarks themselves are not saved. 


Expected results:

Name and Folder fields are available, bookmarks are saved in desired folder after pressing "Bookmark all tabs". I attached a screenshot with ok menu vs broken menu.
Component: Untriaged → Bookmarks & History
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1383138
You need to log in before you can comment on or make changes to this bug.