Closed Bug 1383576 Opened 3 years ago Closed 9 months ago

Intermittent devtools/client/debugger/new/test/mochitest/browser_dbg-breakpoints-reloading.js | Test timed out -

Categories

(DevTools :: Debugger, defect, P3)

defect

Tracking

(firefox56 disabled, firefox57 disabled)

RESOLVED FIXED
Tracking Status
firefox56 --- disabled
firefox57 --- disabled

People

(Reporter: intermittent-bug-filer, Assigned: jlast)

References

Details

(Keywords: intermittent-failure, Whiteboard: [stockwell disabled])

Attachments

(1 file)

this has failed 34 times in the last 4 days, primarily on win7 opt/pgo/debug e10s.

:jlast, can you look into this bug or help find someone to look at it given the frequent failure rates?
Flags: needinfo?(jlaster)
Whiteboard: [stockwell needswork]
We've seen this fail occasionally on the Github CI as well. 

Here is an issue for tracking it:
https://github.com/devtools-html/debugger.html/issues/3336

I'll try and get a fix soon
Flags: needinfo?(jlaster)
I'm extending the timeout window here as I don't see any JS errors. The test is interesting because it has a reload, which often slows the tests down.

https://bugzilla.mozilla.org/show_bug.cgi?id=1385421
:jlast - Frequent failures continue after your efforts in bug 1385421.
Flags: needinfo?(jlaster)
I noticed that. Either we need a longer timeout or find an error. 

My guess is that reloading can sometimes take a bit longer...
Flags: needinfo?(jlaster)
Attached patch timeout2.patchSplinter Review
Attachment #8895044 - Flags: review?(jmaher)
I looked at many of the logs and could not find an error. Also the timeouts seem well distributed.
Comment on attachment 8895044 [details] [diff] [review]
timeout2.patch

Review of attachment 8895044 [details] [diff] [review]:
-----------------------------------------------------------------

lets see if this helps!
Attachment #8895044 - Flags: review?(jmaher) → review+
Keywords: checkin-needed
Assignee: nobody → jlaster
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/1a4526257e09
Extend timeout browser_dbg-breakpoints-reloading. r=jmaher
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/1a4526257e09
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Failures continue.

https://public-artifacts.taskcluster.net/c_k2LQS4Toe8OyrfNDxRSA/0/public/logs/live_backing.log

[task 2017-08-10T01:16:27.038992Z] 01:16:27     INFO - Buffered messages logged at 01:14:14
[task 2017-08-10T01:16:27.040076Z] 01:16:27     INFO - Console message: [JavaScript Warning: "Expected end of value but found ‘!’.  Error in parsing value for ‘width’.  Declaration dropped." {file: "chrome://devtools/content/debugger/new/index.html" line: 0 column: 2 source: "0 !important"}]
[task 2017-08-10T01:16:27.041161Z] 01:16:27     INFO - Console message: [JavaScript Warning: "Expected end of value but found ‘!’.  Error in parsing value for ‘height’.  Declaration dropped." {file: "chrome://devtools/content/debugger/new/index.html" line: 0 column: 2 source: "0 !important"}]
[task 2017-08-10T01:16:27.042530Z] 01:16:27     INFO - Console message: [JavaScript Warning: "Expected end of value but found ‘!’.  Error in parsing value for ‘padding’.  Declaration dropped." {file: "chrome://devtools/content/debugger/new/index.html" line: 0 column: 2 source: "0 !important"}]
[task 2017-08-10T01:16:27.043630Z] 01:16:27     INFO - Console message: [JavaScript Warning: "Expected end of value but found ‘!’.  Error in parsing value for ‘margin-inline-start’.  Declaration dropped." {file: "chrome://devtools/content/debugger/new/index.html" line: 0 column: 8 source: "-1000px !important"}]
[task 2017-08-10T01:16:27.044676Z] 01:16:27     INFO - Console message: [JavaScript Warning: "Expected end of value but found ‘!’.  Error in parsing value for ‘width’.  Declaration dropped." {file: "chrome://devtools/content/debugger/new/index.html" line: 0 column: 2 source: "0 !important"}]
[task 2017-08-10T01:16:27.045724Z] 01:16:27     INFO - Console message: [JavaScript Warning: "Expected end of value but found ‘!’.  Error in parsing value for ‘height’.  Declaration dropped." {file: "chrome://devtools/content/debugger/new/index.html" line: 0 column: 2 source: "0 !important"}]
[task 2017-08-10T01:16:27.046845Z] 01:16:27     INFO - Console message: [JavaScript Warning: "Expected end of value but found ‘!’.  Error in parsing value for ‘padding’.  Declaration dropped." {file: "chrome://devtools/content/debugger/new/index.html" line: 0 column: 2 source: "0 !important"}]
[task 2017-08-10T01:16:27.047925Z] 01:16:27     INFO - Console message: [JavaScript Warning: "Expected end of value but found ‘!’.  Error in parsing value for ‘margin-inline-start’.  Declaration dropped." {file: "chrome://devtools/content/debugger/new/index.html" line: 0 column: 8 source: "-1000px !important"}]
[task 2017-08-10T01:16:27.048879Z] 01:16:27     INFO - Waiting for SYNC_BREAKPOINT to dispatch 2 time(s)
[task 2017-08-10T01:16:27.049813Z] 01:16:27     INFO - SYNC_BREAKPOINT dispatched 1 time(s)
[task 2017-08-10T01:16:27.051488Z] 01:16:27     INFO - Buffered messages logged at 01:14:56
[task 2017-08-10T01:16:27.052392Z] 01:16:27     INFO - Longer timeout required, waiting longer...  Remaining timeouts: 2
[task 2017-08-10T01:16:27.053332Z] 01:16:27     INFO - Buffered messages logged at 01:15:41
[task 2017-08-10T01:16:27.054341Z] 01:16:27     INFO - Longer timeout required, waiting longer...  Remaining timeouts: 1
[task 2017-08-10T01:16:27.055401Z] 01:16:27     INFO - Buffered messages finished
[task 2017-08-10T01:16:27.056373Z] 01:16:27     INFO - TEST-UNEXPECTED-FAIL | devtools/client/debugger/new/test/mochitest/browser_dbg-breakpoints-reloading.js | Test timed out -
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Duplicate of this bug: 1389087
Pushed by jmaher@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/4aac8fc2bd62
disable devtools/client/debugger/new/test/mochitest/browser_dbg-breakpoints-reloading.js. r=me a=testonly
leaving this open, please consider looking into the failure and fixing this in the near future :)
Keywords: leave-open
Whiteboard: [stockwell needswork] → [stockwell disabled]
Priority: -- → P3
Product: Firefox → DevTools
Status: REOPENED → RESOLVED
Closed: 3 years ago9 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.