Last Comment Bug 138363 - runtime (plugins.refresh( ))scan of the Win32 registry for PLID installations
: runtime (plugins.refresh( ))scan of the Win32 registry for PLID installations
Status: VERIFIED DUPLICATE of bug 44973
:
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: x86 Windows 2000
: P1 normal (vote)
: mozilla1.0
Assigned To: Peter Lubczynski
: shrirang khanzode
: Benjamin Smedberg [:bsmedberg]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-18 20:06 PDT by Arun Ranganathan
Modified: 2002-05-13 16:48 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Arun Ranganathan 2002-04-18 20:06:03 PDT
First let me apologize to Mozilla contributors outside the Netscape/AOL
firewall, but I'm going to post an internal link:

http://elwood.mcom.com/arun/plugins/first-install-problem.html

When I get back from vacation, I promise to write this up in for mozilla.org on
Mozilla website.  But the issue is:

We've decided to create a Plugin ID system in the Win32 system registry that
could be extended to other platforms via a flat file.  Gecko needs to parse
these registry entries for plugin information, such as path to module and path
to XPT, in addition to parsing existing plugins directories.  Embedders can
determine their search order on their own.
Comment 1 Arun Ranganathan 2002-04-18 20:06:49 PDT
Nominate as appropriate, but this is the bug logged against Gecko to solve the
first-install problem in the future.
Comment 2 rubydoo123 2002-04-19 10:45:27 PDT
getting this over to Peter's plate
Comment 3 rubydoo123 2002-04-19 14:34:48 PDT
setting this to 1.01, so the infrastructure can start to get put into place.
Comment 4 rubydoo123 2002-05-13 13:39:36 PDT
need to get the PLID support in for RTM
Comment 5 Peter Lubczynski 2002-05-13 16:47:21 PDT
This issue is now being tracked in bug 44973.

*** This bug has been marked as a duplicate of 44973 ***
Comment 6 shrirang khanzode 2002-05-13 16:48:08 PDT
v

Note You need to log in before you can comment on or make changes to this bug.