DevTools Pretty Print doesnt work

RESOLVED FIXED

Status

()

Firefox
Developer Tools: Debugger
RESOLVED FIXED
6 months ago
4 months ago

People

(Reporter: maggus.staab, Unassigned)

Tracking

(Blocks: 1 bug)

56 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 months ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20170723030206

Steps to reproduce:

for some reason, Firefox (and also Chrome62) are not able to pretty-print this minified JS file

http://www.moxiemanager.com/moxiemanager/js/moxman.api.min.js

STR
- open the above url
- open dev tools
- select the file in the source panel
- click "{ }" the prettify button


Actual results:

the "prettyfied" file was somehow reformatted but it is still not readable for a human


Expected results:

a human readable file, at least with some basic formatting which show functions, blocks etc.

Updated

6 months ago
Component: Untriaged → Developer Tools: Debugger
(Reporter)

Comment 1

6 months ago
to add for my STR:

you need to open http://www.moxiemanager.com/demos/ 
which then loads http://www.moxiemanager.com/moxiemanager/js/moxman.api.min.js (the above mentioned JS script))

Updated

6 months ago
Component: Developer Tools: Debugger → Developer Tools: Source Editor

Updated

4 months ago
Component: Developer Tools: Source Editor → Developer Tools: Debugger

Updated

4 months ago
Blocks: 1070862

Comment 2

4 months ago
pretty printing worked for me. Perhaps it's because we updated the pretty print library recently...

https://shipusercontent.com/414f9b1afd92febc73f54d86363051b4/Screen%20Shot%202017-09-29%20at%2012.06.13%20AM.png
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → FIXED
(Reporter)

Comment 3

4 months ago
confirmed, seemed to be fixed on nightly 58.
You need to log in before you can comment on or make changes to this bug.