extreme cpu usage when http proxy is used

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
17 years ago
10 years ago

People

(Reporter: b_ironfist, Unassigned)

Tracking

({perf})

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: ShonenScape
BuildID:    2002041617

When a http proxy is used to connect, during initial page loading cpu usage spikes (up to 100% on my system, p266) causing everything else that may be running on my system - including even basic functions like mouse tracking - to pause/stutter

Reproducible: Sometimes
Steps to Reproduce:
1.Set a http proxy
2.Go to a website (especially one with lots of entities)
3.Watch CPU usage skyrocket

Actual Results:  CPU usage went through the roof causing my system to hang (for milliseconds at a time)

Expected Results:  Moz should not have taken complete control of my CPU

Comment 1

17 years ago
Do you know what proxy server you are using?
Keywords: perf
(Reporter)

Comment 2

17 years ago
Yes, I happen to be using a local proxy app called proxomitron
but the problem occurs even with proxomitron in full bypass mode
and does occur with other (both remote & local) proxies too

Comment 3

17 years ago
I neglected to mention in my previous update that I did not have this problem
with RC1 on Win98.

Comment 4

17 years ago
Reporter, please try the following:
1) archive your old mozilla application data directory somewhere
2) uninstall your version of mozilla, and remove Program Files\mozilla.org
   (or whereever you have installed mozilla)
3) download and install Mozilla RC3
4) Copy the relevant parts of your old profile (address book, bookmarks, mail,
   news) to the new application data directory

See if the problem still exists with and without proxomitron, and please
report the results.

I have been using Junkbuster with Mozilla for the past year without any problems.

If proxomitron is not HTTP1.1 friendly, then then you may want to set
Edit->Preferences->Advanced->HTTP Networking, and check "Use HTTP 1.0"
and report the results.

Comment 5

16 years ago
Resolving as we have not had a reply from reporter.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Duplicate of this bug: 482642
You need to log in before you can comment on or make changes to this bug.