2.23 - 2.58% tp5o_webext % Processor Time (windows7-32) regression on push b19a95c5c5b758ac90d50be3bd137dd3b2c64d75 (Sat Jul 22 2017)

RESOLVED INVALID

Status

()

defect
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: igoldan, Unassigned)

Tracking

({perf, regression, talos-regression})

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Talos has detected a Firefox performance regression from push:

https://hg.mozilla.org/integration/autoland/pushloghtml?changeset=b19a95c5c5b758ac90d50be3bd137dd3b2c64d75

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

  3%  tp5o_webext % Processor Time windows7-32 pgo e10s     42.31 -> 43.41
  2%  tp5o_webext % Processor Time windows7-32 opt e10s     42.84 -> 43.79


You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=8181

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://wiki.mozilla.org/Buildbot/Talos/Tests

For information on reproducing and debugging the regression, either on try or locally, see: https://wiki.mozilla.org/Buildbot/Talos/Running

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Our wiki page outlines the common responses and expectations: https://wiki.mozilla.org/Buildbot/Talos/RegressionBugsHandling
:Mardak This regression was noticed after a fix for the intermitent was pushed. Please take a look over this issue.
Flags: needinfo?(edilee)
bz would know more about potential tp5o performance changes due to bug 1379762. Although I don't see a matching performance improvement when bug 1379762 originally landed…
Flags: needinfo?(edilee) → needinfo?(bzbarsky)
Sorry, I misspoke. Perfherder does indeed show a 3% tp5o_webext improvement when bug 1379762 originally landed:

https://treeherder.mozilla.org/perf.html#/graphs?series=%5Bmozilla-inbound,253b0cc5d9128c21687d9601959e24ebe300df19,1,1%5D&zoom=1500296838522.5654,1500393957463.1829,35.58333293329018,49.67509323291564&selected=%5Bmozilla-inbound,253b0cc5d9128c21687d9601959e24ebe300df19,228316,298889207,1%5D

bz can comment on whether that was expected or not, but having it regress when it was backed out is somewhat expected then.
The third patch in bug 1379762 (the bit that was backed out), was intended as a performance optimization: it bypasses a bunch of work that we don't need to do after load has fired.

I have no idea what tp5o_webext measures, so I can't comment on whether it's expected that it would hit cases where the performance optimization matters.
Flags: needinfo?(bzbarsky)
I believe because this is exactly canceling out the tp5o improvement from bug 1379762 as per comment 4, this is expected. It will probably be improved again when it relands via bug 1383301.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → INVALID
:Mardak Thanks for explaining and closing this bug.
You need to log in before you can comment on or make changes to this bug.