Clamp gamma and contrast for ScaledFontDWrite when creating Skia typeface instead of when setting up ClearType params

RESOLVED FIXED in Firefox 56

Status

()

P3
normal
RESOLVED FIXED
a year ago
11 months ago

People

(Reporter: lsalzman, Assigned: lsalzman)

Tracking

(Depends on: 1 bug)

56 Branch
mozilla56
Unspecified
Windows
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox56 fixed)

Details

(Whiteboard: [gfx-noted])

Attachments

(1 attachment)

(Assignee)

Description

a year ago
Created attachment 8889513 [details] [diff] [review]
clamp gamma/contrast for ScaledFontDWrite when creating SkTypeface

Only clamping when we set up ClearType params leaves the possibility that default params can still have invalid values, which can trigger assertions like in bug 1348584 comment 20. It's better to clamp things when we're creating the Skia typeface, that way Skia always only ever gets valid values.
Attachment #8889513 - Flags: review?(mchang)
Duplicate of this bug: 1383539
Attachment #8889513 - Flags: review?(mchang) → review+

Comment 2

a year ago
Pushed by lsalzman@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/02a519055f6f
clamp gamma/contrast for ScaledFontDWrite when creating SkTypeface. r=mchang

Comment 3

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/02a519055f6f
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
status-firefox56: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
Depends on: 1406694
You need to log in before you can comment on or make changes to this bug.