All users were logged out of Bugzilla on October 13th, 2018

Pocket dropdown no longer works after bug 1355922 (blank popup)

VERIFIED FIXED in Firefox 56

Status

()

--
blocker
VERIFIED FIXED
a year ago
a year ago

People

(Reporter: mkaply, Assigned: mkaply)

Tracking

({regression})

56 Branch
Firefox 56
regression
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox54 unaffected, firefox55 unaffected, firefox56 verified)

Details

Attachments

(1 attachment)

(Assignee)

Description

a year ago
After the checkin for bug 1355922, the pocket dropdown no longer works. It shows up blank.

It appears that libraryButton is null for this line in Pocket.jsm:

   onPanelViewShowing(event) {
     let document = event.target.ownerDocument;
     let window = document.defaultView;
     let iframe = window.pktUI.getPanelFrame();
 
+    let libraryButton = document.getElementById("library-button");
+    BrowserUtils.setToolbarButtonHeightProperty(libraryButton);

I can't link to dxr or searchfox since this code isn't showing up there.
(Assignee)

Updated

a year ago
Blocks: 1355922
Comment hidden (mozreview-request)

Comment 2

a year ago
mozreview-review
Comment on attachment 8889560 [details]
Bug 1383848 - Null check library button since it's not there by default.

https://reviewboard.mozilla.org/r/160576/#review165858
Attachment #8889560 - Flags: review?(jaws) → review+

Comment 3

a year ago
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b0521321d61a
Null check library button since it's not there by default. r=jaws
Assignee: jaws → mozilla
Status: NEW → ASSIGNED
Has Regression Range: --- → yes
Has STR: --- → yes
status-firefox54: --- → unaffected
status-firefox55: --- → unaffected
status-firefox56: --- → affected
status-firefox-esr52: --- → unaffected
Keywords: regression
Version: Trunk → 56 Branch

Comment 8

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/b0521321d61a
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
status-firefox56: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 56
I have reproduced the bug on Nightly according to (2017-07-24)

Fixing bug is verified on Latest Nightly -- 
Build ID   :20170727100347
User Agent :Mozilla/5.0 (Windows NT 6.1; rv:56.0) Gecko/20100101 Firefox/56.0

Tested OS-- Windows7 32bit
QA Whiteboard: [bugday-20170726]

Comment 12

a year ago
[bugday-20170801] 

status-ff56.0a1 : VERIFIED & FIXED.

Managed to reproduce the issue on Firefox Nightly under Windows 10 X 64.

The issue is no more reproducible on Firefox latest Nightly [BuildID : 20170801100311 , 56.0a1 (2017-08-01) (32-bit)]

Updated

a year ago
Status: RESOLVED → VERIFIED
status-firefox56: fixed → verified

Comment 13

a year ago
(In reply to Madhuri from comment #12)
> [bugday-20170801] 
> 
> status-ff56.0a1 : VERIFIED & FIXED.
> 
> Managed to reproduce the issue on Firefox Nightly under Windows 10 X 64.
> 
> The issue is no more reproducible on Firefox latest Nightly [BuildID :
> 20170801100311 , 56.0a1 (2017-08-01) (32-bit)]

[bugday-20170802]  // due to updates on etherpad link.
You need to log in before you can comment on or make changes to this bug.