Status

()

Core
XPCOM
RESOLVED DUPLICATE of bug 139638
16 years ago
10 years ago

People

(Reporter: Mike Baptiste, Assigned: dougt)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I generally install Mozilla as root and then run the short script in the release
notes for multi user use before using Mozilla under a normal userid.

Starting with the 4/16 nightlies, every time I install Mozilla (including RC1),
when I run the multi-user shell script (as root), regxpcom segfaults.  Mozilla
still runs afterward as a normal user, though there seem to be a few more
problems (enigmail does initialize, plus a few other things)  But I'm not sure
if this is the reason.

Note the installer completes normally - its only when regxpcom is run manually
or via the multi user shell script.

I'm running on RedHat 7.2, fully patched with Ximian Gnome and XFree 4.2

I'll be happy ot provide any othe rdebug info you might need.

I've fallen back to the 2002041507 nightly which works fine and regxpcom
executes normally.  There might be a couple later builds that worked, but if
memory serves, 2002041606 or 8 was the first time I saw this problem.

Here's a backtrace from RC1 (2002041711):

(gdb) backtrace
#0  0x0804b9a8 in ?? ()
#1  0x400d4c7d in nsIThread::GetCurrent () from /usr/lib/libxpcom.so
#2  0x400d4d59 in nsIThread::SetMainThread () from /usr/lib/libxpcom.so
#3  0x4008d593 in NS_InitXPCOM2 () from /usr/lib/libxpcom.so
#4  0x400caa6f in NS_GetServiceManager () from /usr/lib/libxpcom.so
#5  0x400c46db in nsGetServiceByContractID::operator() () from /usr/lib/libxpcom.so
#6  0x40107aee in nsCOMPtr_base::assign_from_helper () from /usr/lib/libxpcom.so
#7  0x400d2ba2 in nsEventQueueImpl::NotifyObservers () from /usr/lib/libxpcom.so
#8  0x400d2784 in nsEventQueueImpl::~nsEventQueueImpl () from /usr/lib/libxpcom.so
#9  0x400d29a1 in nsEventQueueImpl::Release () from /usr/lib/libxpcom.so
#10 0x400945f2 in nsSupportsHashtable::ReleaseElement () from /usr/lib/libxpcom.so
#11 0x400932bb in _hashEnumerate () from /usr/lib/libxpcom.so
#12 0x401259a7 in PL_HashTableEnumerateEntries () from /usr/lib/libplds4.so
#13 0x400936e7 in nsHashtable::Enumerate () from /usr/lib/libxpcom.so
#14 0x4009482f in nsSupportsHashtable::Reset () from /usr/lib/libxpcom.so
#15 0x400d38ce in nsEventQueueServiceImpl::~nsEventQueueServiceImpl () from
/usr/lib/libxpcom.so
#16 0x400d39dd in nsEventQueueServiceImpl::Release () from /usr/lib/libxpcom.so
#17 0x40107a7b in nsCOMPtr_base::~nsCOMPtr_base () from /usr/lib/libxpcom.so
#18 0x08048faa in main ()
#19 0x40190316 in __libc_start_main (main=0x8048e14 <main>, argc=1,
ubp_av=0xbffffac4, init=0x8048814 <_init>, fini=0x80490a0 <_fini>, 
    rtld_fini=0x4000d2fc <_dl_fini>, stack_end=0xbffffabc) at
../sysdeps/generic/libc-start.c:129

Comment 1

16 years ago
Also segfaults on debian 2.2r5.
Version: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) Gecko/20020417,
build 2002041711

Comment 2

16 years ago
Also segfaults on AIX 5.1D, Mozilla 1.0rc1 (from www.mozilla.org). Suggest
setting OS to All.

Comment 3

16 years ago
I get this as well on fully patched 7.2

Comment 4

16 years ago
*** Bug 138743 has been marked as a duplicate of this bug. ***

Comment 5

16 years ago
multiuserinstall works for me with RC2
Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.0rc2) Gecko/20020510

Comment 6

16 years ago
This bug makes it very difficult to install Jave, since the standard method for
installing Java requires running regxpcom.  In this case, I run regxpcom as:
    run-mozilla.sh regxpcom /<long-path>/ns610/libjavaplugin_oji.so

Can anyone tell me what regxpcom does, so I can perform its actions manually?

Comment 7

16 years ago
I have the same thing occurring - fresh recompile from CVS - also occurred with
mozilla-1.0.0-9.src.rpm.

#0  0x00000001 in ?? ()
#1  0x400e153f in nsXPTCStubBase::Stub4() () from
/var/tmp/mozilla-1.0.0-root/usr/lib/mozilla-1.0.0/libxpcom.so
#2  0x4015a3ac in mozJSComponentLoader::AutoRegisterComponent(int, nsIFile*,
int*) ()
   from /var/tmp/mozilla-1.0.0-root/usr/lib/mozilla-1.0.0/components/libjsloader.so
#3  0x40159f6d in mozJSComponentLoader::RegisterComponentsInDir(int, nsIFile*) ()
   from /var/tmp/mozilla-1.0.0-root/usr/lib/mozilla-1.0.0/components/libjsloader.so
#4  0x40159e23 in mozJSComponentLoader::AutoRegisterComponents(int, nsIFile*) ()
   from /var/tmp/mozilla-1.0.0-root/usr/lib/mozilla-1.0.0/components/libjsloader.so
#5  0x400ba46a in nsComponentManagerImpl::AutoRegisterImpl(int, nsIFile*, int)
() from /var/tmp/mozilla-1.0.0-root/usr/lib/mozilla-1.0.0/libxpcom.so
#6  0x400bab33 in nsComponentManagerImpl::AutoRegister(nsIFile*) () from
/var/tmp/mozilla-1.0.0-root/usr/lib/mozilla-1.0.0/libxpcom.so
#7  0x08049984 in main ()
#8  0x40197f9a in __libc_start_main () from /lib/libc.so.6

Comment 8

16 years ago

*** This bug has been marked as a duplicate of 139638 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: XPCOM Registry → XPCOM
QA Contact: doug.turner → xpcom
You need to log in before you can comment on or make changes to this bug.