Exiting and immediately re-executing mozilla.exe causes segfault

RESOLVED DUPLICATE of bug 119034

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 119034
16 years ago
13 years ago

People

(Reporter: Richard Godbee, Assigned: Matti)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Closing the last Mozilla window and immediately re-executing mozilla.exe causes
a segfault/GPF in mozilla.exe.  Immediately meaning within a second or two.  The
message shown in the dialog box is:

[titlebar]OleMainThreadWndName: mozilla.exe - Application Error[/titlebar]
The instruction at "0x0077346f" referenced memory at "0x78e9158f".  The memory
could not be "written".

I can reproduce this consistently, and the memory addresses are always the same
as above.

Windows NT 4.0 Workstation (Service Pack 6a)
Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.0rc1) Gecko/20020417 {Build ID:
2002041711}

(Warning: Somewhat educated guess follows.)  I'm using an older machine, a dual
PII/333 with 320 megs of RAM, so when the second instance of mozilla.exe is
started, the first one may still in memory and running (calling objects'
destructors, etc.).  Could the second mozilla process be trying to send a
message to the first to get it to open a new browser window, then getting
confused when the first mozilla process exits?
(Assignee)

Comment 1

16 years ago
should be a dupe of bug 119034

There is also a secon bug about mozilla crashes if the Java Plugin isn't
unloaded fast enough.


*** This bug has been marked as a duplicate of 119034 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.