In Mac, authentication/elevation/ window does not appear when non-admin user tries to update the browser

VERIFIED FIXED in Firefox 55

Status

()

defect
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: Abe_LV, Assigned: dthayer)

Tracking

55 Branch
mozilla56
x86_64
macOS
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox55blocking fixed, firefox56 verified)

Details

Attachments

(1 attachment)

No description provided.
Steps to Reproduce:
1. Install a Firefox 55.0b1 as admin user
2. Switch to non-admin (standard) user and run the installed Firefox build installed in step 1.
3. Go to about:config and change following prefs:
app.update.badgeWaitTime to 10
app.update.lastUpdateTime.background-update-timer to 1
app.update.promptWaitTime to 30
app.update.timerMinimumDelay to 10
4. Exit Firefox
5.Launch same Firefox build with same profile 
6.Hamburger menu badge and then door-hanger appear
7.Click "Restart and Restore" in the doorhanger ui
8.Verify authentication window appears.


Actual Result:
authentication window does not appear

Expected Result:
Authentication window should appear

Additional note:
When "Restart and Restore" is clicked, browser restarts without updates.
Flags: needinfo?(dothayer)
Summary: In Mac aAuthentication/elevation/ window does not appear in mac, when → In Mac, authentication/elevation/ window does not appear when non-admin user tries to update the browser
See Also: → 1382706
Comment on attachment 8889649 [details]
Bug 1383904 - Show old elevation dialog on elevation fail

https://reviewboard.mozilla.org/r/160678/#review165956
Attachment #8889649 - Flags: review?(robert.strong.bugs) → review+
Pushed by kwierso@gmail.com:
https://hg.mozilla.org/mozilla-central/rev/899590a34d56
Show old elevation dialog on elevation fail r=rstrong a=kwierso
https://hg.mozilla.org/mozilla-central/rev/899590a34d56
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
Comment on attachment 8889649 [details]
Bug 1383904 - Show old elevation dialog on elevation fail

RStrong mentioned that we need this fix also uplifted to beta55 in order to fix bug 1382706. A+
Attachment #8889649 - Flags: approval-mozilla-beta+
Assignee: nobody → dothayer
[Tracking Requested - why for this release]:
This fixes a regression on OS X that slipped through due to it using a very non-typical code path. The reason it doesn't have tests is in part due to that this requires the use of OS X authentication services which we can't have automated tests for similar to UAC on Windows.
Flags: in-testsuite-
Flags: needinfo?(dothayer)
Verified as fixed in Nightly builds. Now, the elevation UI is displayed, and the update is applied.
But it still needs to be verified on Beta as well. Leaving the bug as it is until the beta build is ready for testing.
Abe, since you're already familiar with this issue, could you please verify it on 55b13 as well?
Flags: needinfo?(amasresha)
It an update bug. This can not be verified on 55b13 as the patch was not landed on 55b12. 55b13 has the fix but to verify this we need to see the current build (55b13) updating. I think this is the last beta build in 55.
It is verified on Nightly (comment 9) but still, it has to be verified on beta as well.
Flags: needinfo?(amasresha)
It will be verified when the RC build comes out by early next week.
I can create an update xml and provide steps to update 55b13 to 55b13 so this can be verified on beta. Just give me an hour or so.
I do not think we need to verify this bug like that. We need to verify it like what a normal user does.
I'm fine with that though it would be just as valid as far as the client and what actually needs to be tested as using different update channels.
Verified as fixed.
The issue is fixed in beta build as well.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.