Problem in color rendering for jpg's

RESOLVED WORKSFORME

Status

()

Core
ImageLib
RESOLVED WORKSFORME
16 years ago
7 years ago

People

(Reporter: Maksim Likharev, Unassigned)

Tracking

({pp})

Trunk
Future
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.9+)
Gecko/20020418
BuildID:    2002041803

look like it's render it with some alpha channel.
I have put example

Reproducible: Always
Steps to Reproduce:
1.see description
2.
3.
(Reporter)

Comment 1

16 years ago
Created attachment 79950 [details]
html file

just open it and you'll see difference in colors
(Reporter)

Comment 2

16 years ago
Created attachment 79951 [details]
jpg image file
(Reporter)

Comment 3

16 years ago
so it went to 2 different attachments, but you'll need both of them

Updated

16 years ago

Comment 4

16 years ago
BuildID:    2002041603
Result:  Image fits seemlessly into BG color

BuildID:    2002041803
Result:  Color of JPEG it off just like the bug says

So whatever it was, it was checked in sometime between the 16th and the 18th

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.9+)

Comment 5

16 years ago
reassigning
Assignee: morse → pavlov
Component: Image Management → ImageLib
QA Contact: tever → tpreston
This works on Linux....  adding pp and confirming based on Arron's comments.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: pp

Comment 7

16 years ago
This appears to be a Windows Only bug caused by the fix for Bug 135226
I'll add a comment to that bug too.

Comment 8

16 years ago
over to saari based on comments since he owns 135226
Assignee: pavlov → saari
Depends on: 135226

Updated

16 years ago
Target Milestone: --- → mozilla1.0

Comment 9

15 years ago
This bug appears clearly on www.catnip.co.uk where the boundaries between the
background colour and the jpg images are very visible. This is under Linux. The
effect is not visible for png images, nor does it appear on the same box/url
using Konqueror, Opera et al. Whilst it is present on all my Linux boxes, it
seems worse on the ancient ones with old graphics cards.

Comment 10

15 years ago
retargeting
Target Milestone: mozilla1.0 → Future

Comment 11

15 years ago
another, though probably related, issue is also visible at
http://www.macromedia.com/images/master/background.jpg

image is tiled in CSS across the page as a background for the <body> tag, yet
rendered as 8/16bit

running Mac OS X (10.2.8 and 10.3.3) and reproducible in both Firebird 0.7.1 and
Mozilla 1.5
Assignee: saari → nobody
QA Contact: tpreston → imagelib
Testcase is broken and I can't reproduce the issue with the URL given above. If the bug is still reproducible please reopen/file a new bug as this is impossible to fix without a offending JPG if this hasn't been fixed already.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.