Irritating Alert upon HTTP connection refuse

RESOLVED DUPLICATE of bug 28586

Status

()

Core
Networking: HTTP
RESOLVED DUPLICATE of bug 28586
16 years ago
15 years ago

People

(Reporter: Eugenia Loli, Assigned: Darin Fisher)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Hiya, Mozilla RC-1 here under XP PRO.

In my "hosts" file, I have dissallow a big number of advertisers and spyware web
sites, namely, DoubleClick, KaZaA, CometCursor and the like. So, each time I am
going to a news web site that happens to have an iFrame with a doubleclick or
other ad agency advertisement, I always get a pop-up error message saying 
"The connection was refused when attempting to contact to ad.doubleclick.net"
And if I go to a page that has 3 and 4 of these ads, I get the same error
message 3 and 4 times over and orver again. Please take out this error message,
no other browser does it like that. Just display a 404 error or your error
message or whatever inside that iFrame, but do not create new alert windows.
They are really irritating, especially when my own firewall is the one who
created this behaviour anyway and I am fully aware of that!

Best Regards,
Eugenia

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 28586 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
If it is a connection failure, there is no 404, which is a status + error page
in HTML from the web server. 

You shouldn't hack your /etc/hosts file. If you have these sites pointed to
0.0.0.0 or 127.0.0.1, that is not the best way of dealing with ads.
You need to log in before you can comment on or make changes to this bug.