If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

font size in style sheet does not work properly

VERIFIED INVALID

Status

()

Core
CSS Parsing and Computation
VERIFIED INVALID
16 years ago
16 years ago

People

(Reporter: Laesser, Assigned: dbaron)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.9) Gecko/20020311
BuildID:    2002031104

Page at http://www.wapme-systems.com, the text at bottom, defined with
class="main7" by style sheet http://www.wapme-systems.com/css/wsystems4.css
should be smaller.

[Maybe this is caused by wrong CSS or HTML. However, it works on new commercial
browsers properly]

Reproducible: Always
Steps to Reproduce:
1. Go to http://www.wapme-systems.com




Actual Results:  Text defined with class="main7" has not 8point as defined in
http://www.wapme-systems.com/css/wsystems4.css

Expected Results:  It should display this text in 8point

<xmp>
<td valign="top" class="main7">Wapme Systems AG present their new Value Added
Services! For more information, take a look <a href="plmw10.php"
onFocus="blur()" class="main7">here.</a></td>
</xmp>

In this exapmle the text ("here.") is displayed in 8pt. The text ("Wapme Systems
AG present ther...") is not displayed in 8pt.

Comment 1

16 years ago
CSS declaration of .main7 is:

.main7  {
 	font-family:arial;
 	color:#000000;
 	font-size:8pt;
 	vertical-align:top;
 	text-align:left;
 }

a more specific a.main7 is also defined later:

a.main7  		{ font-family:arial; font-size:8pt; vertical-align:top; text-align:left; }

But I'm also seeing the large descrepancy between the two items. Confirming, but
off to look for dupes.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All

Comment 2

16 years ago
Created attachment 80022 [details]
Screen shot showing difference in text sizes

Attaching a screen shot from my mac. Look in the bottom middle to see the
difference in TD and A text.
I have no idea why this should work in other browsers... all the rules in the
stylesheet starting with the |.headline2| rule (the third one) and the
|/*Standart Link*/| comment are commented out. This includes the ".main7" rule
that should affect this font size.

The reason the text in the other cells is smaller is that the a.main7 rule is
not commented out...

NS4 also does this right and the size near the bottom is not 8pt.  I have no IE
to test, but if IE fails on this, it's a bug in the IE CSS parser.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 4

16 years ago
My eyes are going... the close comments are there... i just didn't notice that
they were nested poorly causing invalid css (too many closing "}")... I'd have
to check the spec to see if we're dealing with the errors properly... for
example, when delete the inner contents of the comments we get something like:

.main3  {
 	font-family:arial;
 	color:#000000;
 	font-size:10pt;
 	vertical-align:top;
 	text-align:left;
 }
 
 /**/
 }
 
 /**/
 }
 
 /**/
 }
 
 .main7  {
 	font-family:arial;
 	color:#000000;
 	font-size:8pt;
 	vertical-align:top;
 	text-align:left;
 }

I'm not convinced we are doing the right thing without first looking at the spec.

Comment 5

16 years ago
Created attachment 80162 [details]
cleaned up css file... deleted contents of comments

Comment 6

16 years ago
Created attachment 80164 [details]
Simplified test case showing invalid CSS

Comment 7

16 years ago
Based on the test case I'm reopening this bug. We are ignoring the instruction
after an orphaned "}". As here:

<style type="text/css">
}
h1 { color:green; background-color:white; }
</style>

I know this is invalid CSS (and the author of the original page should fix it),
I just couldn't tell from the parsing instructions in the CSS spec to tell if
this is a valid handling of the error. If it is I'm more then happy with
WONTFIX, but it shouldn't be WONTFIX due to the reasons in comment 3.
Status: RESOLVED → REOPENED
Component: XP Apps → Style System
Resolution: INVALID → ---
reassign to style system for real.  I believe we're correct in ignoring that rule.
Assignee: sgehani → dbaron
Status: REOPENED → NEW
QA Contact: paw → ian
Such a stylesheet isn't even parseable according to either of the CSS grammars.
 I'm not sure whether we're ignoring just the rule or the entire stylesheet, but
either is reasonable.  I'm not sure which CSS3 will say, but we can address it
once it says something.
Status: NEW → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → INVALID
VERIFIED INVALID
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.